n-trig: touch screen non-functional in lucid (single touch)

Bug #541453 reported by rafi on 2010-03-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
linux (Ubuntu)
Undecided
Andy Whitcroft
xf86-input-wacom (Ubuntu)
Undecided
Unassigned

Bug Description

My touch screen doesn't work on a fresh install of lucid alpha 3.

The pen support is autoconfigured to use the wacom X driver, which rejects it because the vendor is not wacom.

The 2.6.32 kernel driver for ntrig also does not work well with the more recent firmwares and needs the fixes that are in 2.6.34-rc1 to get basic functionality working (also improves behavior for older firmwares). But that version also has one identified bug which while bad has only been seen to interfere with the X evdev driver (BTN_TOUCH is not released). The patch I'm including should appear in the mainline eventually, but should be applied to support evdev which is the default handler for touch on this device in lucid.

I'm also including the patched version of hid-ntrig.c

Timo Aaltonen (tjaalton) on 2010-03-18
Changed in lucid:
status: New → Invalid
Bryce Harrington (bryce) wrote :

There were two patches included in the tar. These should be attached separately since they're to two different packages (-wacom and linux). (May have been better to do entirely separate bug reports for each patch, but this is fine this time.)

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Bryce Harrington (bryce) wrote :

The patch to -wacom I uploaded to Lucid March 11th, so this part's already done. That was in version wacom-tools_0.8.4.1-0ubuntu5

Changed in xf86-input-wacom (Ubuntu):
status: New → Fix Released
Bryce Harrington (bryce) wrote :

I'm wrong. I patched wacom-tools rather than xf86-input-wacom. What an idiot I am.

Changed in xf86-input-wacom (Ubuntu):
status: Fix Released → In Progress
Bryce Harrington (bryce) wrote :

Okay *now* it is packaged and uploaded. Since we're frozen for beta1 it won't appear in the archive for another day or two. But please let me know if the issue still exists after updating to xf86-input-wacom_0.10.3+20100109-1ubuntu3

Changed in xf86-input-wacom (Ubuntu):
status: In Progress → Fix Committed
tags: added: patch
Andy Whitcroft (apw) on 2010-03-18
summary: - basic ntrig functionality broken in lucid
+ n-trig: touch screen non-functional in lucid (single touch)
tags: added: kernel-series-unknown
Andy Whitcroft (apw) on 2010-03-19
tags: added: lucid
removed: kernel-series-unknown
Andy Whitcroft (apw) wrote :

@rafi -- the patch presented here does not look at all applicable to the 2.6.32 version of the N-TRIG driver we have in the lucid mainline. It looks wholy dependant on the multi-touch stack in .34-rc1. Is there a simpler version of this patch that sorts out 2.6.32 without bringing in the whole of the driver update?

Changed in linux (Ubuntu):
status: New → Incomplete
rafi (rafi-ugcs) wrote :

The extra kernel patch beyond 34-rc1 was merged by Linus last night:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=c6b9e73f2fee8bb86058f296de808b326473456b

The version of hid-ntrig.c in his HEAD now matches what I proposed.

rafi (rafi-ugcs) wrote :

To clarify:

In order to enable basic pen and single touch functionality for ntrig devices with recent firmwares, the 2.6.32 kernel requires the full set of patches to hid-ntrig.c after 2.6.32 up and including my March 10th patch that was part of last's night's commit in the torvalds repository.

Explanation:
The first three patches were meant to be applied together and serve to compensate for the behavioral change in the firmware. They were broken up to demonstrate the conceptual stages and to simplify review.

The 4th patch adds two lines to clear up a change to restore finger tapping when used with the -wacom X driver.

The 5th and final fixes finger taps for evdev as well as improves the correctness of the emitted protocol.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xf86-input-wacom - 1:0.10.3+20100109-1ubuntu3

---------------
xf86-input-wacom (1:0.10.3+20100109-1ubuntu3) lucid; urgency=low

  * Add 107_ntrig_tabletpc.patch: PCI id for N-Trig TabletPC
    (LP: #541453)
 -- Bryce Harrington <email address hidden> Thu, 18 Mar 2010 14:05:59 -0700

Changed in xf86-input-wacom (Ubuntu):
status: Fix Committed → Fix Released
Aiman Baharna (aiman) on 2010-03-29
affects: lucid → launchpad
affects: launchpad → null
Andy Whitcroft (apw) on 2010-03-31
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
miaou86 (ced56) wrote :

I try the kernel 2.6.32-19.28, the driver for my touch screen does not work.

It is compiled but not used. For the hid-quanta driver works.

in /include/linux/hid.h, change the end of the macro IS_INPUT_APPLICATION to (a >= 0xd0002 && a <= 0xd0006).

replace the line:
#define IS_INPUT_APPLICATION(a) (((a >= 0x00010000) && (a <= 0x00010008)) || (a == 0x00010080) || (a == 0x000c0001) || (a >= 0x000d0002))
by :
#define IS_INPUT_APPLICATION(a) (((a >= 0x00010000) && (a <= 0x00010008)) || (a == 0x00010080) || (a == 0x000c0001) || ((a >= 0x000d0002 && a <= 0x000d0006)))

source : http://www.lii-enac.fr/en/projects/shareit/linux-howto.html
ps: translated by google

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I can confirm that matches Stephane's patch which was applied to the kernel
sometime between 2.6.32 and 2.6.34-rc1.

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8b0e58a70a7a41443c779de074288035b014cb94

On 04/03/10 11:53, miaou86 wrote:
> I try the kernel 2.6.32-19.28, the driver for my touch screen does not
> work.
>
> It is compiled but not used. For the hid-quanta driver works.
>
> in /include/linux/hid.h, change the end of the macro
> IS_INPUT_APPLICATION to (a >= 0xd0002 && a <= 0xd0006).
>
> replace the line:
> #define IS_INPUT_APPLICATION(a) (((a >= 0x00010000) && (a <= 0x00010008)) || (a == 0x00010080) || (a == 0x000c0001) || (a >= 0x000d0002))
> by :
> #define IS_INPUT_APPLICATION(a) (((a >= 0x00010000) && (a <= 0x00010008)) || (a == 0x00010080) || (a == 0x000c0001) || ((a >= 0x000d0002 && a <= 0x000d0006)))
>
> source : http://www.lii-enac.fr/en/projects/shareit/linux-howto.html
> ps: translated by google
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAku3aaMACgkQwuRiAT9o608HSACgoHR05V5K8He9BuYIzDcoGRQx
M5YAoNcUIcJdQDR6DxEVjnj+JXUKfzls
=zWL5
-----END PGP SIGNATURE-----

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers