no backup is performed

Bug #330651 reported by Lubomír Sedlář
Affects Status Importance Assigned to Milestone
Jean-Peer Lorenz

Bug Description

When I run backup, NSsbackup never finishes it. It pops up a notification about the backup sessions starting and then that it started to commit files to disk. Then it starts to use 100 % of CPU and the directory with the backup is created, except the files.tar.bz2 size is 0 and does not change.

I have tried using gzip or not to compress the backup, but it didn't help. I backup on another hard disk in the same computer, it's mounted in /mnt.

I use Debian unstable and NSsbackup version 0.2-0 RC3 (this is written in Help > About) installed from PPA. I have attached a log file NSsbackup creates with level DEBUG.

Revision history for this message
Lubomír Sedlář (lubomir-sedlar) wrote :
Revision history for this message
Jean-Peer Lorenz (peer.loz) wrote :

Hey Lubomír,

I've looked at your log and couldn't find any suspicous output. But please keep in mind: The creation of a full backup of 13GB (in your case) may take some time. And I mean possibly more than 1 hour. This is because NSsbackup runs at nice level 19 to avoid blocking your system. To prove if this is really a hidden bug I suggest the following: configure NSsbackup to perfom a small test backup (some files) and post whether this works for you.

Moreover read the FAQs related to debugging NSsbackup.

(Unsupported hint: you can renice the priority of the spawned backup process to increase speed)

Please post your results.

Changed in nssbackup:
status: New → Incomplete
Revision history for this message
Lubomír Sedlář (lubomir-sedlar) wrote :

I have tried the small test backup and it worked, and with changing the priority, the complete /home directory backup worked too. Is there a way I can force NSsbackup not to change nice to 19?
Anyway, I am sorry for disturbing you with this false bug.

Revision history for this message
Jean-Peer Lorenz (peer.loz) wrote :

At the moment there is no way provided to change the priority. For later release this is a reasonable feature. I've registered a blueprint concerning this topic ( If you want write down some ideas how such feature should work for you and e.g. could be integrated into the GUI.

Thank you.

P.S.: Since this bug is invalid it will be closed.

Changed in nssbackup:
assignee: nobody → peer.loz
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.