n-api should reject requests to detach a volume when the compute is down

Bug #1909120 reported by Lee Yarwood on 2020-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Lee Yarwood
Train
Undecided
Unassigned
Ussuri
Undecided
Unassigned
Victoria
Undecided
Unassigned

Bug Description

Description
===========
At present requests to detach volumes from instances on down computes are accepted by n-api but will never be acted upon if the n-cpu service hosting the instance is down.

n-api should reject such requests with a simple 409 HTTP conflict.

Steps to reproduce
==================
* Attempt to detach a volume from an instance residing on a down compute.

Expected result
===============
Request rejected by n-api

Actual result
=============
Request accepted but never completed

Environment
===========
1. Exact version of OpenStack you are running. See the following
  list for all releases: http://docs.openstack.org/releases/

   Master

2. Which hypervisor did you use?
   (For example: Libvirt + KVM, Libvirt + XEN, Hyper-V, PowerKVM, ...)
   What's the version of that?

   libvirt + QEMU/KVM

2. Which storage type did you use?
   (For example: Ceph, LVM, GPFS, ...)
   What's the version of that?

   N/A

3. Which networking type did you use?
   (For example: nova-network, Neutron with OpenVSwitch, ...)

   N/A

Changed in nova:
status: New → Confirmed
importance: Undecided → Medium
sean mooney (sean-k-mooney) wrote :

updating this to fix release sicne https://review.opendev.org/c/openstack/nova/+/768352 is merged on master

backports have been propsoed to u and v so i have add those and i also added train since i assume we want this in Train downstream?

if this need to go back futher then feel free to add those too but i tred to pick a resonable set of branches.

Changed in nova:
status: Confirmed → Fix Released

This issue was fixed in the openstack/nova 23.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers