console proxy deployment info was removed from cells v2 layout doc

Bug #1846401 reported by melanie witt on 2019-10-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
melanie witt
Train
Low
Matt Riedemann

Bug Description

The information about how console proxies need to be deployed in a multi-cell deployment was mistakenly removed in the following commit as part of nova-consoleauth service docs removal:

https://github.com/openstack/nova/commit/009fd0f35bcb88acc80f12e69d5fb72c0ee5391f#diff-236824986276093f57fa8ba4d3639e68L322

We need to restore the general information for console proxies using the database for storing token authorizations.

melanie witt (melwitt) on 2019-10-02
tags: added: cells console doc
Changed in nova:
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.opendev.org/686271

Changed in nova:
status: New → In Progress
melanie witt (melwitt) on 2019-10-02
tags: added: train-rc-potential
Matt Riedemann (mriedem) wrote :

This is a duplicate of bug 1846045, I was wondering why the fix wasn't tracked there. I'll just duplicate that against this though.

melanie witt (melwitt) wrote :

Er, sorry, I either didn't know there was already a bug filed or I forgot.

melanie witt (melwitt) wrote :

I see now that I commented on the other bug a few days ago... I blame travel brain.

Reviewed: https://review.opendev.org/686271
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=c4d6aabad16383ef046d84b0847515d59f3bdc63
Submitter: Zuul
Branch: master

commit c4d6aabad16383ef046d84b0847515d59f3bdc63
Author: melanie witt <email address hidden>
Date: Wed Oct 2 20:04:48 2019 +0000

    Restore console proxy deployment info to cells v2 layout doc

    This information was mistakenly removed when references to the
    nova-consoleauth service were removed from the docs in change
    Ie96e18ea7762b93b4116b35d7ebcfcbe53c55527.

    Closes-Bug: #1846401

    Change-Id: I08fa4650d190114775993e8094efbf46b984dfdc

Changed in nova:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/686325
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=86c37d783e88d846618032e5569dd24342621bac
Submitter: Zuul
Branch: stable/train

commit 86c37d783e88d846618032e5569dd24342621bac
Author: melanie witt <email address hidden>
Date: Wed Oct 2 20:04:48 2019 +0000

    Restore console proxy deployment info to cells v2 layout doc

    This information was mistakenly removed when references to the
    nova-consoleauth service were removed from the docs in change
    Ie96e18ea7762b93b4116b35d7ebcfcbe53c55527.

    Closes-Bug: #1846401

    Change-Id: I08fa4650d190114775993e8094efbf46b984dfdc
    (cherry picked from commit c4d6aabad16383ef046d84b0847515d59f3bdc63)

This issue was fixed in the openstack/nova 20.0.0.0rc2 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers