docs: Flavors in nova - custom resource classes and overrides

Bug #1800663 reported by Matt Riedemann on 2018-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Takashi NATSUME
Queens
Low
Takashi NATSUME
Rocky
Low
Takashi NATSUME

Bug Description

- [x] This is a doc addition request.

The nova flavor user guide doesn't mention the ability to specify custom resource classes on a flavor, or how to override standard resource classes, introduced in this spec in Pike:

https://specs.openstack.org/openstack/nova-specs/specs/pike/implemented/custom-resource-classes-in-flavors.html#data-model-impact

The ironic flavor guide is probably the most comprehensive for this, so maybe the nova flavor docs can just reference that for details:

https://docs.openstack.org/ironic/latest/install/configure-nova-flavors.html

-----------------------------------
Release: 18.1.0.dev629 on 2018-10-30 13:27
SHA: d1e38f06bb5282dd9bf81d979926a0ebbfd93caa
Source: https://git.openstack.org/cgit/openstack/nova/tree/doc/source/user/flavors.rst
URL: https://docs.openstack.org/nova/latest/user/flavors.html

Changed in nova:
assignee: nobody → Takashi NATSUME (natsume-takashi)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/616721
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=0e718ddb7a43230fa1ae9ee2d78c4375a964cd48
Submitter: Zuul
Branch: master

commit 0e718ddb7a43230fa1ae9ee2d78c4375a964cd48
Author: Takashi NATSUME <email address hidden>
Date: Fri Nov 9 09:47:17 2018 +0900

    Add description of custom resource classes

    Add the description about custom resource classes and
    overriding standard resource classes in the "Flavors" document.

    Change-Id: I5b804db70d229696e7b7c5b5db16946cf1f1c49f
    Closes-Bug: #1800663

Changed in nova:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/619122
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=e54c5fbe2df7324a75612e01433356a6b7fc1d14
Submitter: Zuul
Branch: stable/rocky

commit e54c5fbe2df7324a75612e01433356a6b7fc1d14
Author: Takashi NATSUME <email address hidden>
Date: Fri Nov 9 09:47:17 2018 +0900

    Add description of custom resource classes

    Add the description about custom resource classes and
    overriding standard resource classes in the "Flavors" document.

    Change-Id: I5b804db70d229696e7b7c5b5db16946cf1f1c49f
    Closes-Bug: #1800663
    (cherry picked from commit 0e718ddb7a43230fa1ae9ee2d78c4375a964cd48)

This issue was fixed in the openstack/nova 18.1.0 release.

Reviewed: https://review.openstack.org/619125
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=fee13a41c77edebeaef0ed37b149d5b6ef86fe5b
Submitter: Zuul
Branch: stable/queens

commit fee13a41c77edebeaef0ed37b149d5b6ef86fe5b
Author: Takashi NATSUME <email address hidden>
Date: Fri Nov 9 09:47:17 2018 +0900

    Add description of custom resource classes

    Add the description about custom resource classes and
    overriding standard resource classes in the "Flavors" document.

    Conflicts:
        doc/source/user/flavors.rst

    Due to: The following changes are not backported.

      * I9bd80adc244c64277d2d00e7d79c3002c8f9d57e
      * Ifb99e727110c4904a85bc4a13366c2cae300b8df

    Change-Id: I5b804db70d229696e7b7c5b5db16946cf1f1c49f
    Closes-Bug: #1800663
    (cherry picked from commit 0e718ddb7a43230fa1ae9ee2d78c4375a964cd48)
    (cherry picked from commit e54c5fbe2df7324a75612e01433356a6b7fc1d14)

This issue was fixed in the openstack/nova 19.0.0.0rc1 release candidate.

This issue was fixed in the openstack/nova 17.0.10 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers