nova-consoleauth missing from Rocky install guide; unable to use VNC

Bug #1793255 reported by end-user on 2018-09-19
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Matt Riedemann
Rocky
High
Matt Riedemann

Bug Description

You gus doesn't maintain the doc well. Waste people lots of time.

openstack-nova-consoleauth should be started, or VNC console won't work.

see https://bugs.launchpad.net/nova/+bug/1792674

================================================

This bug tracker is for errors with the documentation, use the following as a template and remove or add fields as you see fit. Convert [ ] into [x] to check boxes:

- [x] This doc is inaccurate in this way: ______
- [ ] This is a doc addition request.
- [ ] I have a fix to the document that I can paste below including example: input and output.

If you have a troubleshooting or support issue, use the following resources:

 - Ask OpenStack: http://ask.openstack.org
 - The mailing list: http://lists.openstack.org
 - IRC: 'openstack' channel on Freenode

-----------------------------------
Release: 18.0.1.dev30 on 2018-09-19 04:24
SHA: a936ecb280de74339e3de8ba8a42bd6e9458b7f5
Source: https://git.openstack.org/cgit/openstack/nova/tree/doc/source/install/controller-install-rdo.rst
URL: https://docs.openstack.org/nova/rocky/install/controller-install-rdo.html

Matt Riedemann (mriedem) wrote :

Installing nova-consoleauth was removed from the docs in Rocky as part of this change:

https://review.openstack.org/#/c/565367/

Need to talk to melwitt about this.

tags: added: consoleauth doc
Changed in nova:
status: New → Confirmed
importance: Undecided → High
summary: - Install and configure controller node for Red Hat Enterprise Linux and
- CentOS in nova
+ nova-consoleauth missing from Rocky install guide; unable to use VNC
Matt Riedemann (mriedem) wrote :

Should have been fixed as part of this:

https://review.openstack.org/#/q/4f01f4ff88de571218a36ba7c4e998296a7b52a4

Just need to re-add those docs it looks like, along with a deprecation warning in the install guide.

Fix proposed to branch: master
Review: https://review.openstack.org/605154

Changed in nova:
assignee: nobody → melanie witt (melwitt)
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/605250

Change abandoned by melanie witt (<email address hidden>) on branch: master
Review: https://review.openstack.org/605154
Reason: We need to do more than this and un-deprecate nova-consoleauth, so the revert is here:

https://review.openstack.org/605250

Change abandoned by melanie witt (<email address hidden>) on branch: master
Review: https://review.openstack.org/605255
Reason: Instead of un-deprecating, we fixed the code to actually make nova-consoleauth optional:

https://review.openstack.org/607068

Change abandoned by melanie witt (<email address hidden>) on branch: stable/rocky
Review: https://review.openstack.org/607038
Reason: Instead of un-deprecating, we fixed the code to actually make nova-consoleauth optional:

https://review.openstack.org/607068

Matt Riedemann (mriedem) wrote :

We continue to get bugs in triage for the rocky install docs not saying that nova-consoleauth should be installed (duplicated to this bug). So I think we need to say *something* in the install guide about the nova-consoleauth service install (which was removed in https://review.openstack.org/#/c/565367/) - maybe it would be as simple as adding a note and linking to the workaround config option for more details:

https://docs.openstack.org/nova/rocky/configuration/config.html#workarounds.enable_consoleauth

Matt Riedemann (mriedem) wrote :

Also see related bug 1798188. I'm not sure if this should be duplicated against that or not.

Changed in nova:
assignee: melanie witt (melwitt) → Matt Riedemann (mriedem)
Matt Riedemann (mriedem) wrote :

I have restored https://review.openstack.org/#/c/605154/ and updated it.

melanie witt (melwitt) wrote :

Since https://review.openstack.org/610673 merged, it should not be required to install nova-consoleauth unless the [workarounds]enable_consoleauth config option has been set to True by the operator.

Reviewed: https://review.openstack.org/605154
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=983e6ea5518dee956d8054cd67dddbe98eab9f78
Submitter: Zuul
Branch: master

commit 983e6ea5518dee956d8054cd67dddbe98eab9f78
Author: melanie witt <email address hidden>
Date: Tue Sep 25 17:12:16 2018 +0000

    Restore nova-consoleauth to install docs

    The installation of the nova-consoleauth service was erroneously
    removed from the docs prematurely. The nova-consoleauth service
    is still being used in Rocky, with the removal being possible in
    Stein.

    This should have been fixed as part of change
    Ibbdc7c50c312da2acc59dfe64de95a519f87f123 but was missed.

    This is also related to the release note update in Rocky
    under change Ie637b4871df8b870193b5bc07eece15c03860c06.

    Co-Authored-By: Matt Riedemann <email address hidden>

    Closes-Bug: #1793255
    Related-Bug: #1798188

    Change-Id: Ied268da9e70bd2807c2dfe7a479181fbec52979d

Changed in nova:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/630997
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=7a0203c9ad1b10596f5de0d0954ee3ccb356d685
Submitter: Zuul
Branch: stable/rocky

commit 7a0203c9ad1b10596f5de0d0954ee3ccb356d685
Author: melanie witt <email address hidden>
Date: Tue Sep 25 17:12:16 2018 +0000

    Restore nova-consoleauth to install docs

    The installation of the nova-consoleauth service was erroneously
    removed from the docs prematurely. The nova-consoleauth service
    is still being used in Rocky, with the removal being possible in
    Stein.

    This should have been fixed as part of change
    Ibbdc7c50c312da2acc59dfe64de95a519f87f123 but was missed.

    This is also related to the release note update in Rocky
    under change Ie637b4871df8b870193b5bc07eece15c03860c06.

    Co-Authored-By: Matt Riedemann <email address hidden>

    Closes-Bug: #1793255
    Related-Bug: #1798188

    Change-Id: Ied268da9e70bd2807c2dfe7a479181fbec52979d
    (cherry picked from commit 983e6ea5518dee956d8054cd67dddbe98eab9f78)

This issue was fixed in the openstack/nova 19.0.0.0rc1 release candidate.

This issue was fixed in the openstack/nova 18.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers