Comment 1 for bug 1788833

Matt Riedemann (mriedem) wrote :

(10:56:34 AM) diliprenkila: <mriedem> diliprenkila oslo.db==4.40.0 ,oslo.messaging==8.1.0 on the compute nodes and oslo.db==4.38.0, oslo.messaging==6.4.1 on the nova controller node

Stephen already pointed out that this is the breaking nova change:

https://github.com/openstack/nova/commit/2d532963fa2e013e16cc403f2674a4488c4170ab#diff-8fec546e4c39f78d233f8e21dadaa3ff

which depends on this oslo.db change:

https://github.com/openstack/oslo.db/commit/df6bf3401266f42271627c1e408f87c71a06cef7

Which was released in oslo.db 4.40 but we don't require that min version in rocky for nova, so that's the failure. You need oslo.db >= 4.40.