VM cannot get fixed IP after live migration successfully

Bug #1677937 reported by huan on 2017-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
huan
Ocata
High
Matt Riedemann

Bug Description

I'm using XenServer 7.0 XenAPI driver + upstream

I found VM can live migration successfully with XenServer hypervisor, but after migrating to destination host, we cannot ping the VM's floatig or fix IP anymore.
After using our XenCenter to login to the VM, I found the VM even doesn't have fixed IP via DHCP. So checking the coded and found out although live migration is done successfully, but during live migration, the driver only create the network in destination host for the VM's VIF to connect, but lack of linux bridge and the corresponding connection to ovs bridge br-int.

huan (huan-xie) on 2017-03-31
Changed in nova:
assignee: nobody → huan (huan-xie)
Andrey Volkov (avolkov) on 2017-03-31
tags: added: live-migration xen
Changed in nova:
status: New → In Progress
Jay Pipes (jaypipes) on 2017-06-07
Changed in nova:
importance: Undecided → High

Change abandoned by Huan Xie (<email address hidden>) on branch: master
Review: https://review.openstack.org/451657

huan (huan-xie) wrote :

I have made another patch to fix this bug https://review.openstack.org/#/c/462017/, so abandon the previous https://review.openstack.org/451657

Reviewed: https://review.openstack.org/462017
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=d89fe544bd5b119ab6fe24d6a353240efbf5a491
Submitter: Jenkins
Branch: master

commit d89fe544bd5b119ab6fe24d6a353240efbf5a491
Author: Huan Xie <email address hidden>
Date: Wed May 3 00:19:21 2017 -0700

    XenAPI: Create linux bridge in dest host during live migration

    We found VM can live migrate successfully with XenServer hypervisor,
    but after migrating to dest host, we cannot ping the VM's floating
    or fixed IP any more. The problem is, during live migration, we only
    create the network in dest host which the VM's VIF connect to, but we
    don't establish the linux bridge and the corresponding veth pair to
    integration bridge br-int.

    Closes-Bug: 1677937

    Change-Id: I0d69d2ba5b064ef303445892791804608e7f19c5

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 16.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/475902
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=e74c207676db55edf44e70174cebfa48c7f5be48
Submitter: Jenkins
Branch: stable/ocata

commit e74c207676db55edf44e70174cebfa48c7f5be48
Author: Huan Xie <email address hidden>
Date: Wed May 3 00:19:21 2017 -0700

    XenAPI: Create linux bridge in dest host during live migration

    We found VM can live migrate successfully with XenServer hypervisor,
    but after migrating to dest host, we cannot ping the VM's floating
    or fixed IP any more. The problem is, during live migration, we only
    create the network in dest host which the VM's VIF connect to, but we
    don't establish the linux bridge and the corresponding veth pair to
    integration bridge br-int.

    Closes-Bug: 1677937

    Change-Id: I0d69d2ba5b064ef303445892791804608e7f19c5
    (cherry picked from commit d89fe544bd5b119ab6fe24d6a353240efbf5a491)

This issue was fixed in the openstack/nova 15.0.7 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers