CellsV1 regression introduced with flavor migration to api database

Bug #1663729 reported by Dan Smith on 2017-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Dan Smith
Newton
Medium
Matt Riedemann
Ocata
Medium
Matt Riedemann

Bug Description

In Newton we migrated flavors to the api database, which requires using the Flavor object for proper compatibility. A piece of cellsv1 was missed which would cause it to start reporting resources incorrectly after the migration happened and the flavors are removed from the main database.

Dan Smith (danms) on 2017-02-10
tags: added: newton-backport-potential
Changed in nova:
assignee: nobody → Dan Smith (danms)
status: New → In Progress
Dan Smith (danms) on 2017-02-10
tags: added: ocata-backport-potential
Matt Riedemann (mriedem) on 2017-02-10
Changed in nova:
importance: Undecided → High

Reviewed: https://review.openstack.org/432352
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=6e5b1d289b68f635d369dc092eff5595fb12c331
Submitter: Jenkins
Branch: master

commit 6e5b1d289b68f635d369dc092eff5595fb12c331
Author: Dan Smith <email address hidden>
Date: Fri Feb 10 07:37:51 2017 -0800

    Remove straggling use of main db flavors in cellsv1 code

    This remaining use of the flavor query routine from the cellsv1 code
    still looks at the main database. This patch converts it to use the
    object which looks in the right place.

    Closes-Bug: #1663729
    Change-Id: I418988ae1d72d541ace867a22b2c9267164bf61b

Changed in nova:
status: In Progress → Fix Released

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/433922

Reviewed: https://review.openstack.org/432688
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=681e3776187d3ce3f7ccba8da056c007aa570232
Submitter: Jenkins
Branch: stable/ocata

commit 681e3776187d3ce3f7ccba8da056c007aa570232
Author: Dan Smith <email address hidden>
Date: Fri Feb 10 07:37:51 2017 -0800

    Remove straggling use of main db flavors in cellsv1 code

    This remaining use of the flavor query routine from the cellsv1 code
    still looks at the main database. This patch converts it to use the
    object which looks in the right place.

    Closes-Bug: #1663729
    Change-Id: I418988ae1d72d541ace867a22b2c9267164bf61b
    (cherry picked from commit 6e5b1d289b68f635d369dc092eff5595fb12c331)

Change abandoned by Matt Riedemann (<email address hidden>) on branch: stable/newton
Review: https://review.openstack.org/433014
Reason: https://review.openstack.org/#/c/433922/

Reviewed: https://review.openstack.org/433922
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=f2ea55fe953107e0a406c5a934c3a6d8b0bebfd5
Submitter: Jenkins
Branch: stable/newton

commit f2ea55fe953107e0a406c5a934c3a6d8b0bebfd5
Author: Dan Smith <email address hidden>
Date: Fri Feb 10 07:37:51 2017 -0800

    Remove straggling use of main db flavors in cellsv1 code

    This remaining use of the flavor query routine from the cellsv1 code
    still looks at the main database. This patch converts it to use the
    object which looks in the right place.

    Conflicts:
            nova/tests/unit/cells/test_cells_state_manager.py

    NOTE(mriedem): The conflict is due to not having
    c9de74ac2a618f1f85cffaaf5210f07b8329cc05 in newton.

    Closes-Bug: #1663729
    Change-Id: I418988ae1d72d541ace867a22b2c9267164bf61b
    (cherry picked from commit 6e5b1d289b68f635d369dc092eff5595fb12c331)
    (cherry picked from commit 681e3776187d3ce3f7ccba8da056c007aa570232)

This issue was fixed in the openstack/nova 15.0.0.0rc2 release candidate.

This issue was fixed in the openstack/nova 14.0.4 release.

This issue was fixed in the openstack/nova 16.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers