OpenStack Compute (Nova)

ConfigOpts doesn't find policy.json and api-paste.ini

Reported by Rick Harris on 2012-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Rick Harris

Bug Description

Commit `16c5dbf156f5aafe113d9ac2c26e99b0e621724d` refactored the code to use ConfigOpts.find_file from openstack.common instead Nova's custom version.

The code is breaking for me because it's searching /etc/ and not /etc/nova (where I've always stored my development config files).

The root cause appears to be not passing in the `project` identifier into the ConfigOpts initializer.

Changed in nova:
assignee: nobody → Rick Harris (rconradharris)
importance: Undecided → Medium
status: New → In Progress

Reviewed: https://review.openstack.org/7407
Committed: http://github.com/openstack/nova/commit/fb96f7dff66e35f59a568e592ecea3bd5e500287
Submitter: Jenkins
Branch: master

commit fb96f7dff66e35f59a568e592ecea3bd5e500287
Author: Rick Harris <email address hidden>
Date: Mon May 14 20:06:45 2012 +0000

    Pass 'nova' project into ConfigOpts.

    Fixes bug 999305

    The problem was that, post refactoring, `ConfigOpts.find_file` was no
    longer searching `/etc/nova` for config files.

    Change-Id: I3dee8d8f24ae3912e07dcb9d19086d55eb98ccaa

Changed in nova:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2012-05-22
Changed in nova:
milestone: none → folsom-1
Thierry Carrez (ttx) on 2012-05-23
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in nova:
milestone: folsom-1 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers