OpenStack Compute (Nova)

Unable to retrieve details for instance due to volumes KeyError

Reported by Edward on 2012-05-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
John Griffith

Bug Description

2012-05-14 17:33:45 ERROR nova.api.openstack [req-1ba6a344-0926-48ea-bd6d-3b0b6fe4afe9 bfd3e40ff1c944f3be55ee9bcc80a93f 998e7097d08849308919271ac47f498c] Caught error: 'volumes'
2012-05-14 17:33:45 TRACE nova.api.openstack Traceback (most recent call last):
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/__init__.py", line 41, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return req.get_response(self.application)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/request.py", line 1053, in get_response
2012-05-14 17:33:45 TRACE nova.api.openstack application, catch_exc_info=False)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/request.py", line 1022, in call_application
2012-05-14 17:33:45 TRACE nova.api.openstack app_iter = application(self.environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 159, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return resp(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/keystone/keystone/middleware/auth_token.py", line 176, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return self.app(env, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 159, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return resp(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 159, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return resp(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 159, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return resp(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/routes/middleware.py", line 131, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack response = self.app(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 159, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack return resp(environ, start_response)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 147, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack resp = self.call_func(req, *args, **self.kwargs)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/usr/local/lib/python2.7/dist-packages/WebOb-1.0.8-py2.7.egg/webob/dec.py", line 208, in call_func
2012-05-14 17:33:45 TRACE nova.api.openstack return self.func(req, *args, **kwargs)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/wsgi.py", line 803, in __call__
2012-05-14 17:33:45 TRACE nova.api.openstack content_type, body, accept)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/wsgi.py", line 851, in _process_stack
2012-05-14 17:33:45 TRACE nova.api.openstack action_result = self.dispatch(meth, request, action_args)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/wsgi.py", line 926, in dispatch
2012-05-14 17:33:45 TRACE nova.api.openstack return method(req=request, **action_args)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/compute/contrib/volumes.py", line 294, in index
2012-05-14 17:33:45 TRACE nova.api.openstack entity_maker=_translate_attachment_summary_view)
2012-05-14 17:33:45 TRACE nova.api.openstack File "/opt/stack/nova/nova/api/openstack/compute/con
trib/volumes.py", line 394, in _items
2012-05-14 17:33:45 TRACE nova.api.openstack volumes = instance['volumes']
2012-05-14 17:33:45 TRACE nova.api.openstack KeyError: 'volumes'
2012-05-14 17:33:45 TRACE nova.api.openstack

Edward (zhang-hare) wrote :
Changed in nova:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → John Griffith (john-griffith)
summary: - Unable to retrieve details for instance due to volumes KyeError
+ Unable to retrieve details for instance due to volumes KeyError

Fix proposed to branch: master
Review: https://review.openstack.org/7406

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/7406
Committed: http://github.com/openstack/nova/commit/f0dd8b0af87cf5d838457100430b529379d70916
Submitter: Jenkins
Branch: master

commit f0dd8b0af87cf5d838457100430b529379d70916
Author: John Griffith <email address hidden>
Date: Mon May 14 14:01:32 2012 -0600

    get instance details results in volumes key error

    * fixes bug 999043
    * this code was still looking for instance FK in volumes
    * changed contrib/compute volume.api:attach to use bdm
    * added minimal tests for changes in Attach class

    Change-Id: I19c7aff25182aa55741ec4d80b7e30f7e66ca998

Changed in nova:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2012-05-22
Changed in nova:
milestone: none → folsom-1
Thierry Carrez (ttx) on 2012-05-23
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in nova:
milestone: folsom-1 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions