OpenStack Compute (Nova)

exclude xenapi plugins from pep8/hacking checks

Reported by Dan Prince on 2012-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Dan Prince

Bug Description

The Xenapi plugins are currently written in Python 2.4. As such they do not satisfy all of our pep8 checks.

Lets just exclude them for now. These plugins arguably shouldn't be in Nova's code base anyway.

Dan Prince (dan-prince) wrote :

The offending file is 'glance' plugin which makes use of md5.

tools/hacking.py:122: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  __import__(mod, globals(), locals(), [], -1)

Changed in nova:
assignee: nobody → Dan Prince (dan-prince)
importance: Undecided → Low
status: New → In Progress

Reviewed: https://review.openstack.org/6708
Committed: http://github.com/openstack/nova/commit/2b490fd2ef3a74402147893be646c00505da8628
Submitter: Jenkins
Branch: master

commit 2b490fd2ef3a74402147893be646c00505da8628
Author: Dan Prince <email address hidden>
Date: Sun Apr 22 21:11:03 2012 -0400

    Exclude xenapi plugins from pep8/hacking checks.

    Fixes LP Bug #987055.

    Change-Id: I7132b88c5e0a90b16d0f8e35df45b82e7991280f

Changed in nova:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2012-05-22
Changed in nova:
milestone: none → folsom-1
Thierry Carrez (ttx) on 2012-05-23
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in nova:
milestone: folsom-1 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers