Instance vm_state remains 'migrating' if source compute node goes down during migration

Bug #973393 reported by Unmesh Gurjar
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
Medium
Jian Wen

Bug Description

Scenario: During live migration of an instance, if the source Compute node goes down, the instance vm_state remains set to 'migrating'.

Expected Behavior: The instance state must be updated to vm_state to 'error'.

Actual Behavior: Instance remains in following state vm_state=migrating, task_state=NULL, power_state=1

Such instances should be monitored and the vm_state must be updated to 'error'. Because until the source compute server comes up, no actions can be performed on the instance.

Tags: ntt
Changed in nova:
assignee: nobody → Unmesh Gurjar (unmesh-gurjar)
Revision history for this message
Thierry Carrez (ttx) wrote :

Which version did you see that with ? Any chance you could check with current Folsom ?

Changed in nova:
assignee: Unmesh Gurjar (unmesh-gurjar) → nobody
status: New → Incomplete
Revision history for this message
Thierry Carrez (ttx) wrote :

We cannot solve the issue you reported without more information. Could you please provide the requested information ?

Revision history for this message
Unmesh Gurjar (unmesh-gurjar) wrote :

I missed this one.
This scenario is a corner case. It can be reproduced on master branch, if the source Compute server goes down immediately after it picks the 'live_migration' request from Rabbit queue.

Jian Wen (wenjianhn)
Changed in nova:
assignee: nobody → Jian Wen (wenjianhn)
status: Incomplete → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (master)

Fix proposed to branch: master
Review: https://review.openstack.org/19616

Changed in nova:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (master)

Reviewed: https://review.openstack.org/19616
Committed: http://github.com/openstack/nova/commit/be62d6a86971abac57a1cc03c985ba1e97fd55cb
Submitter: Jenkins
Branch: master

commit be62d6a86971abac57a1cc03c985ba1e97fd55cb
Author: Jian Wen <email address hidden>
Date: Mon Jan 14 19:13:24 2013 +0800

    Handle compute node not available for live migration

    This patch handles exception.ComputeServiceUnavailable by restoring
    instance's vm_state and instance's task_state after live migration
    failure caused by unavailable source/dest compute node.

    Raises detailed HTTPBadRequest explanation for this exception.

    Fixes bug 973393 and bug 1051881

    Change-Id: If825b61fad9c4e3030f2e6c5002907255eaf3661

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx)
Changed in nova:
milestone: none → grizzly-3
status: Fix Committed → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (stable/folsom)

Fix proposed to branch: stable/folsom
Review: https://review.openstack.org/22873

Changed in nova:
importance: Undecided → Medium
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (stable/folsom)

Reviewed: https://review.openstack.org/22873
Committed: http://github.com/openstack/nova/commit/20294279ee1d6d82dbb87c4c29e3a8b9fd0cb8bd
Submitter: Jenkins
Branch: stable/folsom

commit 20294279ee1d6d82dbb87c4c29e3a8b9fd0cb8bd
Author: Jian Wen <email address hidden>
Date: Mon Jan 14 19:13:24 2013 +0800

    Handle compute node not available for live migration

    This patch handles exception.ComputeServiceUnavailable by restoring
    instance's vm_state and instance's task_state after live migration
    failure caused by unavailable source/dest compute node.

    Raises detailed HTTPBadRequest explanation for this exception.

    Fixes bug 973393 and bug 1051881

    Conflicts:
     nova/scheduler/driver.py
     nova/scheduler/manager.py
     nova/tests/api/openstack/compute/contrib/test_admin_actions.py
     nova/tests/scheduler/test_scheduler.py

    Change-Id: If825b61fad9c4e3030f2e6c5002907255eaf3661

Thierry Carrez (ttx)
Changed in nova:
milestone: grizzly-3 → 2013.1
Sean Dague (sdague)
no longer affects: nova/folsom
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers