OpenStack Compute (Nova)

Touch in use image files when they're checked

Reported by Michael Still on 2012-03-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Michael Still

Bug Description

It was intended that FLAGS.remove_unused_resized_minimum_age_seconds
would indicate the number of seconds a base file was unused before it
was removed. This however isn't true at the moment. Because instances
are COW mostly, this will be the time since the resize occurred,
which is normally instantly true once the image isn't being used any
more.

Changed in nova:
status: New → In Progress
Thierry Carrez (ttx) on 2012-03-29
Changed in nova:
importance: Undecided → Medium

Reviewed: https://review.openstack.org/5900
Committed: http://github.com/openstack/nova/commit/2c5112e5938e3d567504748f923fb198fad3117e
Submitter: Jenkins
Branch: master

commit 2c5112e5938e3d567504748f923fb198fad3117e
Author: Michael Still <email address hidden>
Date: Wed Mar 28 21:13:26 2012 +1100

    Touch in use image files when they're checked.

    It was intended that FLAGS.remove_unused_resized_minimum_age_seconds
    would indicate the number of seconds a base file was unused before it
    was removed. This however isn't true at the moment. Because instances
    are COW mostly, this will be the time since the resize occurred,
    which is normally instantly true once the image isn't being used any
    more. This small patch corrects that by touching the base image during
    check cycles which find it in use. Resolves bug 967845.

    Change-Id: I75bf06cf758c9a2d7a8bde5ce67c789d7e299174

Changed in nova:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/6024
Committed: http://github.com/openstack/nova/commit/cd83d0a2f4e7f170c4042ff3ac39fa27f6a7d46a
Submitter: Jenkins
Branch: milestone-proposed

commit cd83d0a2f4e7f170c4042ff3ac39fa27f6a7d46a
Author: Michael Still <email address hidden>
Date: Wed Mar 28 21:13:26 2012 +1100

    Touch in use image files when they're checked.

    It was intended that FLAGS.remove_unused_resized_minimum_age_seconds
    would indicate the number of seconds a base file was unused before it
    was removed. This however isn't true at the moment. Because instances
    are COW mostly, this will be the time since the resize occurred,
    which is normally instantly true once the image isn't being used any
    more. This small patch corrects that by touching the base image during
    check cycles which find it in use. Resolves bug 967845.

    Change-Id: I75bf06cf758c9a2d7a8bde5ce67c789d7e299174

Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: none → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers