Remove nova-manage user list and project list as they are confusing in a Keystone world

Bug #964055 reported by Joseph Heck
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
Wishlist
Brian Waldon

Bug Description

(NOTE: I'm not entirely sure this is correct)

with auth_strategy=keystone configured in Nova, the "nova-manage project list" should (i think) return a list of "tenants" from Keystone.

and the "nova-manage user list" should (I think) return a list of users.

Am I way off base here?

Tags: nova-manage
Revision history for this message
Mark McLoughlin (markmc) wrote :

I think the idea is that these commands are specific to deprecated auth and will be removed when that is removed in Folsom. It is kinda confusing, though

Revision history for this message
Vish Ishaya (vishvananda) wrote :

I would prefer to remove these completely. Since deprecated auth is only in to allow migrations it might be ok to remove these now, but perhaps we should just have a big deprecated warning telling people to use keystone.

Thierry Carrez (ttx)
tags: added: nova-manage
removed: python-novaclient
summary: - with keystone configured, nova-manage user list and project list should
- report keystone data
+ Remove nova-manage user list and project list as they are confusing in a
+ Keystone world
Changed in nova:
importance: Undecided → Wishlist
milestone: none → folsom-2
status: New → Confirmed
Thierry Carrez (ttx)
Changed in nova:
milestone: folsom-2 → none
Revision history for this message
Brian Waldon (bcwaldon) wrote :
Changed in nova:
assignee: nobody → Brian Waldon (bcwaldon)
status: Confirmed → Fix Committed
milestone: none → folsom-3
Thierry Carrez (ttx)
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in nova:
milestone: folsom-3 → 2012.2
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints