OpenStack Compute (Nova)

Extended status extension should not be admin-only

Reported by Anthony Young on 2012-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Anthony Young

Bug Description

By default, the extended status extension, which reports the task_state and power_state of instances, should not be admin only. This is very useful debugging information for admins and regular users alike, and by default should be enabled.

Steps to reproduce:

> (run devstack)
> launch instance as demo user

Expected:

Instance list in horizon displays task and power state for the instance

Actual:

Task=None
Power State=No State

http://stsh.me/1Pr

Fix proposed to branch: master
Review: https://review.openstack.org/5385

Changed in nova:
assignee: nobody → Anthony Young (sleepsonthefloor)
status: New → In Progress

If this patch is not accepted: https://review.openstack.org/5385 then we should probably remove these columns for the user instance list.

(above comment #2 was actually intended for the related horizon bug https://bugs.launchpad.net/horizon/+bug/955735)

Reviewed: https://review.openstack.org/5385
Committed: http://github.com/openstack/nova/commit/b76abb654762adaa401c28e7f54da9ace5ecf72e
Submitter: Jenkins
Branch: master

commit b76abb654762adaa401c28e7f54da9ace5ecf72e
Author: Anthony Young <email address hidden>
Date: Wed Mar 14 23:04:03 2012 -0700

    Make extended status not admin-only by default.

     * Fixes bug 955737
     * Fixes bug 955735

    Change-Id: Ie8d6b67b50d50390edabdde180ed6e29764e2041

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
milestone: none → essex-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers