OpenStack Compute (Nova)

nova api returns an error 500 while asking server details using application/xml

Reported by Giuseppe Civitella on 2012-03-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Vish Ishaya

Bug Description

When performing a query to a nova api server (version Essex4, it does not happen on Essex2) asking for a specific server details using application/xml, the server returns an error 500.
The nova-api log show something like:

http://paste.openstack.org/show/8226/

It does not happen when using a json request.

Fix proposed to branch: master
Review: https://review.openstack.org/5206

Changed in nova:
assignee: nobody → Vish Ishaya (vishvananda)
status: New → In Progress
Changed in nova:
milestone: none → essex-rc1
importance: Undecided → High

Reviewed: https://review.openstack.org/5206
Committed: http://github.com/openstack/nova/commit/c87dce824f81d0ecc0455ae6ed8dfd85fb0bc62a
Submitter: Jenkins
Branch: master

commit c87dce824f81d0ecc0455ae6ed8dfd85fb0bc62a
Author: Vishvananda Ishaya <email address hidden>
Date: Sat Mar 10 15:31:55 2012 -0800

    Fixes xml representation of ext_srv_attr extension

     * adds tests for xml extended_server_attributes
     * modifies extended_status to match
     * fixes bug 951863

    Change-Id: I54aa55bac9ce62b071e62c510ba1b71f1d5b1288

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers