OpenStack Compute (Nova)

novaclient proxy_token behavior broken

Reported by Michael Basnight on 2012-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Michael Basnight

Bug Description

The proxy_token behavior is no longer working with keystone. Keystone even took out the functionality all together. Ive re-added the functionality to keystone via (https://bugs.launchpad.net/keystone/+bug/948439). In doing this, it changes the expected behavior of how novaclient should work. novaclient will need updating to be able to work with it. Ive got a fix that will rename token to proxy_token everywhere, since thats how its used anyway, and add the proxy_tenant_id so that it will work together in happiness.

Changed in nova:
assignee: nobody → Michael Basnight (hubcap)
status: New → In Progress
Michael Basnight (hubcap) wrote :

depends on 948439

Michael Basnight (hubcap) wrote :

We might want to wait a bit on merging this. Id rather change keystone so that we can pass the tenant_name instead of the tenant_id, like the porjectid is now (just the name of the tenant). Ill talk w/ the keystone devs to see if we can change the belongs_to validation from the above bug to depend on tenant name instead of id.

Michael Basnight (hubcap) wrote :

ok thinking more on this it should be fine as is. When keystone started using tenantIDs then moved back to tenantName, yall didnt change the python novaclients' projectid field. its the same here, it will be the name (hopefully) eventually but for now its the id. Even if it switches to name, we dont have to rename it persay. So there is nothing left to do, just to wait for keystone :D

Changed in nova:
importance: Undecided → High
milestone: none → essex-rc1

Reviewed: https://review.openstack.org/5018
Committed: http://github.com/openstack/python-novaclient/commit/4ff001d2322cc5c3e14f8c9901b289c2a64fd172
Submitter: Jenkins
Branch: master

commit 4ff001d2322cc5c3e14f8c9901b289c2a64fd172
Author: Michael Basnight <email address hidden>
Date: Tue Mar 6 22:40:28 2012 -0600

    Fixes lp#948685 proxy_token and proxy_tenant_id behavior

    * renamed token to proxy_token because of its usage
    * added a proxy_tenant_id for new keystone tokens/id/?belongsTo

    Change-Id: Ic7e65612620e5a54f04eddb79bffed7e2df6fba2

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers