OpenStack Compute (Nova)

Missing rootwrap filters for newly-introduced run_as_root commands

Reported by Thierry Carrez on 2012-02-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Thierry Carrez

Bug Description

New run_as_root commands have been recently added but did not provide corresponding rootwrap filters:

* ovs-ofctl (nova/network/linux_net.py)
* cp, rm (nova/virt/disk/api.py)
* mkfs (nova/virt/xenapi/vm_utils.py)

Otherwise anything using rootwrap will fail to execute those commands.

Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
assignee: nobody → Thierry Carrez (ttx)
status: Confirmed → In Progress
Thierry Carrez (ttx) wrote :

Actually I don't think the use of "rm" as root is warranted.

Reviewed: https://review.openstack.org/4697
Committed: http://github.com/openstack/nova/commit/5bcbb65f3c0383a22ebb749a9251f689755e464c
Submitter: Jenkins
Branch: master

commit 5bcbb65f3c0383a22ebb749a9251f689755e464c
Author: Thierry Carrez <email address hidden>
Date: Wed Feb 29 16:22:42 2012 +0100

    Add missing filters for new root commands

    Add missing rootwrap filters for 'ovs-ofctl', 'cp' and 'mkfs'.
    Do not run 'rm' as root since it's unnecessary.
    Add documentation to try to prevent future misses.
    Fixes bug 943293.

    Change-Id: Ia680048a28a75f661a136d8447ff0aaf195649ba

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-01
Changed in nova:
milestone: none → essex-4

Reviewed: https://review.openstack.org/4744
Committed: http://github.com/openstack/nova/commit/73dfd4ea0d369cb1b88a4f66eb55f3587993b83a
Submitter: Jenkins
Branch: milestone-proposed

commit 73dfd4ea0d369cb1b88a4f66eb55f3587993b83a
Author: Thierry Carrez <email address hidden>
Date: Wed Feb 29 16:22:42 2012 +0100

    Add missing filters for new root commands

    Add missing rootwrap filters for 'ovs-ofctl', 'cp' and 'mkfs'.
    Do not run 'rm' as root since it's unnecessary.
    Add documentation to try to prevent future misses.
    Fixes bug 943293.

    Change-Id: Ia680048a28a75f661a136d8447ff0aaf195649ba

Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers