Traceback running instance-usage-audit

Bug #934539 reported by Monsyne Dragon on 2012-02-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Monsyne Dragon

Bug Description

root@nova:~# /usr/bin/instance-usage-audit

Creating usages for 2012-02-15 00:00:00 until 2012-02-16 00:00:00

1759 instances

2012-02-16 16:28:12,887 CRITICAL nova [req-2b0760fc-b06d-4477-a7cb-8cb15dc20a8b None None] Instance 829 could not be found.

(nova): TRACE: Traceback (most recent call last):

(nova): TRACE: File "/usr/bin/instance-usage-audit", line 75, in <module>

(nova): TRACE: nova.compute.utils.notify_usage_exists(instance_ref)

(nova): TRACE: File "/usr/lib/python2.6/dist-packages/nova/compute/utils.py", line 57, in notify_usage_exists

(nova): TRACE: instance_ref)

(nova): TRACE: File "/usr/lib/python2.6/dist-packages/nova/network/api.py", line 225, in get_instance_nw_info

(nova): TRACE: raise exception.InstanceNotFound(instance_id=instance['id'])

(nova): TRACE: InstanceNotFound: Instance 829 could not be found.

(nova): TRACE:

root@nova:~#

Monsyne Dragon (mdragon) on 2012-02-17
Changed in nova:
assignee: nobody → Monsyne Dragon (mdragon)

Fix proposed to branch: master
Review: https://review.openstack.org/4287

Changed in nova:
status: New → In Progress

Reviewed: https://review.openstack.org/4287
Committed: http://github.com/openstack/nova/commit/13789e970beaf932add81f71a2ab528aa309a231
Submitter: Jenkins
Branch: master

commit 13789e970beaf932add81f71a2ab528aa309a231
Author: Monsyne Dragon <email address hidden>
Date: Fri Feb 17 22:11:46 2012 +0000

    Fix traceback running instance-usage-audit

    There were two errors here:
        1 was a missed joinload that was causing an error pulling info_cache.
        2 the exception listed in the bug, which was caused by tring to load data for a deleted instance.

    This fixes bug 934539

    Change-Id: Ifffb6a35c1f7bf8caa6f57d33b29b58d0dbe10b3

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers