OpenStack Compute (Nova)

compile_diagnostics in xenapi erronously catch XenAPI.Failure

Reported by Armando Migliaccio on 2012-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Armando Migliaccio

Bug Description

If I have a webserver on my local machine, this test fails because get_rrd is not stubbed out and host is 127.0.0.1.

Besides, test_diagnostics is not very strong as it only checks that the vmops.get_diagnostics does no throw up. It'd be better if it tested that it worked as it's meant to.

This is on Nova trunk+some bits.

Changed in nova:
status: New → Confirmed
assignee: nobody → Armando Migliaccio (armando-migliaccio)
description: updated
description: updated

It turns out this bug is not exactly what I had initially thought, however I found another problem with compile_diagnostics, which tries to catch XenAPI.Failures on xml parsing. That's clearly not going to work. Fix coming shortly.

summary: - test_diagnostics in xenapi interferes with local system
+ compile_diagnostics in xenapi erronously catch XenAPI.Failure

Fix proposed to branch: master
Review: https://review.openstack.org/3964

Changed in nova:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/3966

Reviewed: https://review.openstack.org/3966
Committed: http://github.com/openstack/nova/commit/8297a1bed0b00447bd01a4501ab9eac88a5865e3
Submitter: Jenkins
Branch: master

commit 8297a1bed0b00447bd01a4501ab9eac88a5865e3
Author: Armando Migliaccio <email address hidden>
Date: Thu Feb 9 15:53:50 2012 +0000

    bug 929462: compile_diagnostics in xenapi erronously catch XenAPI.Failure

    ensure we catch the right exception. Plus turn test_diagnostics into a
    more thorough unit test.

    Change-Id: I1aae28b9b3b942f08e419cd9cfa48dea003e96d9

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers