OpenStack Compute (Nova)

Require SA-Migrate 0.7.2 and SA 0.7.3 or greater

Reported by Rick Harris on 2012-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Rick Harris

Bug Description

Migrate 075 appears to do some fanciness which breaks under sa-migrate 0.7.1: http://paste.openstack.org/show/4735/

Upgrading sqlalchemy and sa-migrate fixes this; so we should require >= the latest.

$ pip freeze | grep lchem

SQLAlchemy==0.7.3
sqlalchemy-migrate==0.7.2

Changed in nova:
assignee: nobody → Rick Harris (rconradharris)
importance: Undecided → High
status: New → In Progress

Reviewed: https://review.openstack.org/3883
Committed: http://github.com/openstack/nova/commit/71247a627e367e8732f583fb4e197c23f0b5ec6f
Submitter: Jenkins
Branch: master

commit 71247a627e367e8732f583fb4e197c23f0b5ec6f
Author: Rick Harris <email address hidden>
Date: Wed Feb 8 05:33:40 2012 +0000

    Require newer versions of SA and SA-Migrate

    Fixes bug 928637

    Change-Id: I27d06d945449f70a6da00c1f5d306bd5fe43b253

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers