OpenStack Compute (Nova)

Nova notifications now seem to be using the default rabbit exchange

Reported by Matt Dietz on 2012-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Monsyne Dragon

Bug Description

Rather than using the "nova" exchange, notifications appear to be using the default exchange.

As such, any existing notifications configurations are broken. They can be fixed in the interim by setting the exchange type to be None (depending on the library you use)

Please include unit tests to ensure this doesn't happen again

Thierry Carrez (ttx) on 2012-01-13
Changed in nova:
importance: Undecided → High
milestone: none → essex-3
status: New → Confirmed
Thierry Carrez (ttx) on 2012-01-24
Changed in nova:
assignee: nobody → Monsyne Dragon (mdragon)
Thierry Carrez (ttx) on 2012-01-25
Changed in nova:
milestone: essex-3 → none
Monsyne Dragon (mdragon) wrote :

Was finally able to replicate. Problem does not actually seem to be the wrong exchange. Rather, the 'durable' flag is not being applied correctly to the notification queues, which is where the issue was noted.

Fix proposed to branch: master
Review: https://review.openstack.org/3476

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3476
Committed: http://github.com/openstack/nova/commit/2a846859f4e1959660a6895bfbb6b8d5f87e14c3
Submitter: Jenkins
Branch: master

commit 2a846859f4e1959660a6895bfbb6b8d5f87e14c3
Author: Monsyne Dragon <email address hidden>
Date: Thu Jan 26 19:57:32 2012 +0000

    Fixes bug 914418

    This turns out not to actually be a case of using the wrong exchange, rather
    it is that the exchange's 'durable' flag does not match the queue if FLAGS.durable is set to 'False'.

    Change-Id: I69ac7e84ac02a72dd204fa3aa27e73637594f509

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers