OpenStack Compute (Nova)

Resizes should be automatically confirmed after 24 hours

Reported by Thierry Carrez on 2012-01-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Wishlist
Philip Knouff

Bug Description

From Nachi on the ML:

The doc says *All resizes are automatically confirmed after 24 hours
if they are not explicitly confirmed or reverted*, but I couldn't
find such implementation.

Thierry Carrez (ttx) on 2012-01-13
Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in nova:
assignee: nobody → Philip Knouff (philip-knouff)
status: Confirmed → In Progress
Brian Waldon (bcwaldon) wrote :

This is already implemented in the xenapi driver. Looks like we just need to fill in the _poll_unconfirmed_resizes method in the libvirt driver and we can close this.

Reviewed: https://review.openstack.org/4024
Committed: http://github.com/openstack/nova/commit/b3a88b528648423c4854f6c9f882857fd3320365
Submitter: Jenkins
Branch: master

commit b3a88b528648423c4854f6c9f882857fd3320365
Author: Philip Knouff <email address hidden>
Date: Wed Feb 8 19:53:32 2012 -0500

    Automatic confirmation of resizes on libvirt

    fixes bug #911217

    Change-Id: I135002a3010416e8c63b3dce303f4e4d47c7c6d3

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers