OpenStack Compute (Nova)

Provide a script to automate cleanup of _base

Reported by Michael Still on 2011-12-15
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
nova (Ubuntu)
Medium
Unassigned

Bug Description

The nova base instance directory $instances_path/_base is never cleaned up. This caused one of my compute nodes to run out of disk recently, even though a bunch of the images there were no longer in use. There appear to be homebrew cleanup scripts online, such as https://github.com/Razique/BashStuff/blob/master/SCR_5008_V00_NUAC-OPENSTACK-Nova-compute-images-prunning.sh . Please provide a script to perform cleanup in the package.

Scott Moser (smoser) wrote :
Changed in nova (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in nova:
status: New → Confirmed
Michael Still (mikalstill) wrote :

I have just send a patch for review which implements the _base cleanup aspects of the blueprint. Its integrated into the nova compute manager, as opposed to being a separate script.

https://review.openstack.org/#change,2902

James Troup (elmo) on 2012-03-05
tags: added: canonistack
Thierry Carrez (ttx) wrote :

Looks like this landed in E4. Please reopen if there is more to it.

Changed in nova:
status: Confirmed → Fix Released
Bolke de Bruin (bolke-de-bruin) wrote :

What happens if I trun on the cleanup and I have instances residing on a glusterfs. Briefly reading the code (Ubuntu essex release) the image does not get marked in use and will be removed. Is that correct?

If so, would this be configurable let's say with a "instances_path_is_shared" flag?

Michael Still (mikalstill) wrote :

Bolke -- that's not currently the case. If you want this functionality you should file a separate bug for it. However, with a shared instances directory you're best off disabling the cache manager entirely at the moment.

Dave Walker (davewalker) wrote :

Marking Ubuntu task as fix released, as this should be included with Essex-4 milestone and above. If this is not the case, please re-adjust the status as appropriate. Thanks.

Changed in nova (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers