Application/server name not available in service logs

Bug #904307 reported by Unmesh Gurjar on 2011-12-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Undecided
Unassigned
Cinder
Wishlist
Liyingjun
Glance
Wishlist
Julia Varlamova
Murano
Wishlist
Xurong Yang
OpenStack Compute (nova)
Wishlist
Liyingjun
OpenStack Identity (keystone)
Wishlist
Brant Knudson
Sahara
Fix Released
Wishlist
Sergey Lukjanov
neutron
Wishlist
Liyingjun
oslo-incubator
Wishlist
Bogdan Dobrelya

Bug Description

If Nova is configured to use syslog based logging, and there are multiple services running on a system, it becomes difficult to identify the service that emitted the log. This can be resolved if the log record also contains the name of the service/binary that generated the log. This will also be useful with an OpenStack system using a centralized syslog based logging mechanism.

Thierry Carrez (ttx) on 2011-12-21
Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed
Russell Bryant (russellb) wrote :

Since the log code has moved to oslo-incubator, we need to add something to the log module there first.

Mark McLoughlin (markmc) on 2013-03-12
Changed in oslo:
status: New → Confirmed
importance: Undecided → Wishlist

Fix proposed to branch: master
Review: https://review.openstack.org/63094

Changed in oslo:
assignee: nobody → Bogdan Dobrelya (bogdando)
status: Confirmed → In Progress
Changed in oslo:
milestone: none → icehouse-3
Bogdan Dobrelya (bogdando) wrote :

Added use_syslog_rfc_format option (default false) to control APP-NAME insertion for syslog handler

Bogdan Dobrelya (bogdando) wrote :

Updated docs for new option added notices about deprecation in J and incoming logging format changes as well.

Bogdan Dobrelya (bogdando) wrote :

Added all affected core projects to not forgot to update them in I-3 as well

Feilong Wang (flwang) on 2014-01-22
Changed in glance:
importance: Undecided → Wishlist
status: New → Triaged

Reviewed: https://review.openstack.org/63094
Committed: https://git.openstack.org/cgit/openstack/oslo-incubator/commit/?id=79e8a9a08daf563aa8a8d9280c9a6a27dcafc8f2
Submitter: Jenkins
Branch: master

commit 79e8a9a08daf563aa8a8d9280c9a6a27dcafc8f2
Author: Bogdan Dobrelya <email address hidden>
Date: Thu Dec 19 13:46:55 2013 +0200

    Backport 'ident' from python 3.3 for Oslo's SysLogHandler

    To honor RFC5424 add use_syslog_rfc_format config option
    (default False, would be deprecated in J after existing
    syslog format deprecation) which adds APP-NAME to syslog message
    before MSG part to reflect application or service name.
    Usable only with use_syslog, otherwise ignored.

    During J, the default logging format for syslog should be changed
    to always provide APP-NAME, thus use_syslog_rfc_format could be
    deprecated in J as well.

    DocImpact
    Closes-bug: #904307

    Change-Id: I3815e6dc47e206e15f9da90ebbba5ca00c3ae641
    Signed-off-by: Bogdan Dobrelya <email address hidden>
    Signed-off-by: Bogdan Dobrelya <email address hidden>

Changed in oslo:
status: In Progress → Fix Committed
Dolph Mathews (dolph) on 2014-01-27
Changed in keystone:
status: New → Triaged
importance: Undecided → Wishlist
Changed in glance:
assignee: nobody → Julia Varlamova (jvarlamova)

Fix proposed to branch: master
Review: https://review.openstack.org/72327

Changed in glance:
status: Triaged → In Progress
Changed in murano:
importance: Undecided → Wishlist
milestone: none → 0.5
status: New → Confirmed
Changed in savanna:
importance: Undecided → Wishlist
milestone: none → next
status: New → Confirmed
Liyingjun (liyingjun) on 2014-02-13
Changed in nova:
assignee: nobody → Liyingjun (liyingjun)

Fix proposed to branch: master
Review: https://review.openstack.org/73340

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/72327
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=954073d0f26c5b2bbe86a2099158de57911a1a1c
Submitter: Jenkins
Branch: master

commit 954073d0f26c5b2bbe86a2099158de57911a1a1c
Author: Julia Varlamova <email address hidden>
Date: Mon Feb 10 16:12:25 2014 +0400

    Sync log.py from oslo

    Add use_syslog_rfc_format config option. Default value is False.
    If enabled, will add APP-NAME before the MSG part of the syslog message.

    Fixes bug: #904307

    Change-Id: Idd664bc98532e3a557dde5cbee213ca597d4e2e5

Changed in glance:
status: In Progress → Fix Committed
Liyingjun (liyingjun) on 2014-02-19
Changed in cinder:
assignee: nobody → Liyingjun (liyingjun)

Fix proposed to branch: master
Review: https://review.openstack.org/74568

Changed in cinder:
status: New → In Progress
Liyingjun (liyingjun) on 2014-02-19
Changed in keystone:
assignee: nobody → Liyingjun (liyingjun)
Changed in keystone:
status: Triaged → In Progress
Liyingjun (liyingjun) on 2014-02-19
Changed in neutron:
assignee: nobody → Liyingjun (liyingjun)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/74577

Changed in neutron:
status: Confirmed → In Progress
lvdongbing (dbcocle) on 2014-02-19
Changed in heat:
assignee: nobody → lvdongbing (dbcocle)
status: New → In Progress
Changed in savanna:
importance: Wishlist → Low
milestone: next → icehouse-3
status: Confirmed → Fix Committed
importance: Low → Wishlist
lvdongbing (dbcocle) on 2014-02-19
Changed in ceilometer:
assignee: nobody → lvdongbing (dbcocle)
status: New → Confirmed
Changed in savanna:
assignee: nobody → Sergey Lukjanov (slukjanov)
lvdongbing (dbcocle) on 2014-02-19
Changed in ceilometer:
assignee: lvdongbing (dbcocle) → nobody
lvdongbing (dbcocle) on 2014-02-20
Changed in ceilometer:
status: Confirmed → Fix Committed
Changed in keystone:
assignee: Liyingjun (liyingjun) → Brant Knudson (blk-u)
Thierry Carrez (ttx) wrote :

The rootwrap-related part of the change applied to oslo-incubator should have been rejected, since rootwrap was frozen in oslo-incubator while graduating to a separate library. Now that code change was lost and needs to be reapplied to oslo.rootwrap instead.

Changed in oslo:
status: Fix Committed → Triaged

Reviewed: https://review.openstack.org/73340
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=35ee11438d75dcb7af11bfe6a651cc190872263d
Submitter: Jenkins
Branch: master

commit 35ee11438d75dcb7af11bfe6a651cc190872263d
Author: liyingjun <email address hidden>
Date: Wed Jan 15 14:43:36 2014 +0800

    Sync log.py from oslo

    This change syncs log.py from oslo-incubator with commit
    79e8a9a08daf563aa8a8d9280c9a6a27dcafc8f2

    To honor RFC5424 add use_syslog_rfc_format config option
    (default False, would be deprecated in J after existing
    syslog format deprecation) which adds APP-NAME to syslog message
    before MSG part to reflect application or service name.
    Usable only with use_syslog, otherwise ignored.

    During J, the default logging format for syslog should be changed
    to always provide APP-NAME, thus use_syslog_rfc_format could be
    deprecated in J as well.

    Since the rootwrap code was graduating to a separate library,
    so the rootwrap related change should just go into oslo.rootwrap
    and when oslo.rootwrap is released, nova will pull in the library.

    Change-Id: I6018c7322314a4b57052be1ec0fc5fa437069f44
    Closes-bug: 904307

Changed in nova:
status: In Progress → Fix Committed
Changed in cinder:
importance: Undecided → Wishlist
Changed in oslo:
status: Triaged → Fix Committed
Xurong Yang (idopra) on 2014-02-24
Changed in murano:
assignee: nobody → Xurong Yang (idopra)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/73026
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=40cff9016629374c8418088f20ff61a9201076f8
Submitter: Jenkins
Branch: master

commit 40cff9016629374c8418088f20ff61a9201076f8
Author: Brant Knudson <email address hidden>
Date: Wed Feb 12 13:17:16 2014 -0600

    Update oslo-incubator log.py to a01f79c

    This updates the log module from oslo-incubator to
    a01f79c3050962fd744239956e9654407d14ea1f

     $ git checkout a01f79c3050962fd744239956e9654407d14ea1f
     $ python update.py --nodeps --base keystone \
         --dest-dir ../keystone --modules log

    This includes a fix for the deprecated logger that caused the
    deprecated message to be printed multiple times rather than once.

    Change-Id: I6174b064205adcdc9fb966a9e01eb5190b5b730e
    Closes-Bug: #904307
    Closes-Bug: #1266812

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-05
Changed in savanna:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-03-05
Changed in glance:
milestone: none → icehouse-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-03-05
Changed in nova:
status: Fix Committed → Fix Released
milestone: none → icehouse-3
Thierry Carrez (ttx) on 2014-03-05
Changed in keystone:
milestone: none → icehouse-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-03-05
Changed in ceilometer:
milestone: none → icehouse-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-03-06
Changed in oslo:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/74568
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=aa6b58b5d21ab35e3a32858e3131679b933cef27
Submitter: Jenkins
Branch: master

commit aa6b58b5d21ab35e3a32858e3131679b933cef27
Author: liyingjun <email address hidden>
Date: Thu Jan 16 07:03:28 2014 +0800

    Sync log.py from oslo

    This change syncs log.py from oslo-incubator with the
    following commit:
    * Backport 'ident' from python 3.3 for Oslo's SysLogHandler
      79e8a9a08daf563aa8a8d9280c9a6a27dcafc8f2
    * default connectionpool to WARN log level:
      1978114030c275c571a1786644a5e0d51ada29c0
    * Fix deprecated messages sent multiple times
      52b64466177b58c8e80bc72c5ce1e940782c969a
    * Remove None for dict.get()
      86707cd5c01a2de6b9ba386d7ea4f72c9c7286b1
    * Rename Openstack to OpenStack
      61ff7a66fef51ba2a783a5ed87e14256a6e9432c
    * Use ContextFormatter for imparting context info
      dda47c9cef19c5d8f050cf5081535b4061024457

    Change-Id: I14c3d7eccc596783e380ebd57110337d3ce49038
    Closes-bug: 904307

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/73581
Committed: https://git.openstack.org/cgit/stackforge/murano-conductor/commit/?id=f0d4ae6d90ca75ea01179698ddd3c8c814339278
Submitter: Jenkins
Branch: master

commit f0d4ae6d90ca75ea01179698ddd3c8c814339278
Author: Ekaterina Fedorova <email address hidden>
Date: Thu Mar 6 17:52:19 2014 +0400

    Update openstack/common.log from openstack oslo

    Closes-Bug: #904307
    Change-Id: I7255f37d770c9b04efe22f1160eb2b24fa129aac

Changed in murano:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-27
Changed in cinder:
milestone: none → icehouse-rc1
status: Fix Committed → Fix Released
Changed in neutron:
importance: Undecided → Wishlist
Bogdan Dobrelya (bogdando) wrote :

related Py26 compatibilty issue https://bugs.launchpad.net/oslo/+bug/1306559

Bogdan Dobrelya (bogdando) wrote :

There is an Oslo-rootwrap part https://review.openstack.org/#/c/75807/ had been merged, hence should be synced as well.
I'm not sure how to track this 2nd part of the patch which unlike to the 1st one should go to the another repo, so I jut put it here.
Should I create a separate issue for it and link all OS projects again or is it OK to continue this one?

Doug Hellmann (doug-hellmann) wrote :

Bogdan, if you have more changes for oslo-related repositories just leave oslo set as "in progress" until they are all done.

Thierry Carrez (ttx) on 2014-04-17
Changed in oslo:
milestone: icehouse-3 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in keystone:
milestone: icehouse-3 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in ceilometer:
milestone: icehouse-3 → 2014.1
Bogdan Dobrelya (bogdando) wrote :

>>>Bogdan, if you have more changes for oslo-related repositories just leave oslo set as "in progress" until they are all done.

Sorry, I cannot change state from "Fix released" to "in progress". Hope we'd not lose rootwrap sync part...

Thierry Carrez (ttx) on 2014-04-17
Changed in nova:
milestone: icehouse-3 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-rc1 → 2014.1
Bogdan Dobrelya (bogdando) wrote :

related issue with fix suggested for Oslo-incubator https://bugs.launchpad.net/nova/+bug/1306559 (should be synced once merged)

Thierry Carrez (ttx) on 2014-04-17
Changed in glance:
milestone: icehouse-3 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in sahara:
milestone: icehouse-3 → 2014.1
Changed in murano:
status: Fix Committed → Fix Released
Angus Salkeld (asalkeld) on 2014-10-03
Changed in heat:
importance: Undecided → Wishlist
milestone: none → next
Elena Ezhova (eezhova) wrote :

As the log module was synced from oslo in https://review.openstack.org/#/c/128284/ the fix for Neutron can be considered committed.

Changed in neutron:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-02-05
Changed in neutron:
milestone: none → kilo-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in neutron:
milestone: kilo-2 → 2015.1.0
Changed in heat:
status: In Progress → Triaged
assignee: lvdongbing (dbcocle) → nobody
Changed in heat:
assignee: nobody → Kanagaraj Manickam (kanagaraj-manickam)
Thomas Herve (therve) on 2016-04-19
no longer affects: heat
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers