OpenStack Compute (Nova)

docs don't build properly in virtualenv

Reported by Monty Taylor on 2011-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Monty Taylor
OpenStack Core Infrastructure
Low
Unassigned

Bug Description

If you run:

tools/with_venv.sh python setup.py build_sphinx

The build will fail with an error about not being able to find a css file. The css file exists, but somewhere for some reason when running in a virtualenv the path lookup that's being done in docutils gets broken.

This only happens in Nova, which is perplexing. It's probably a bug in docutils, plus something we're doing in nova but not elsewhere.

Thierry Carrez (ttx) on 2011-12-21
Changed in nova:
importance: Undecided → Low
status: New → Confirmed
Monty Taylor (mordred) on 2012-01-05
description: updated
Monty Taylor (mordred) on 2012-01-05
Changed in openstack-ci:
status: New → Triaged
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.openstack.org/4951

Changed in nova:
assignee: nobody → Monty Taylor (mordred)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/4951
Committed: http://github.com/openstack/nova/commit/3b081fea0868070a10ffb924a51314af24438e74
Submitter: Jenkins
Branch: master

commit 3b081fea0868070a10ffb924a51314af24438e74
Author: Monty Taylor <email address hidden>
Date: Mon Mar 5 20:17:41 2012 -0800

    Finally fix the docs venv bug.

    Closes bug 902846.

    Turns out that without providing a default css file,
    docutils tries to pull one in from a location using
    very bad path logic. Glance was providing the css file
    explicitly and it worked, so I just copied them.

    Change-Id: I6cc9d0ca148149637104c27f6c020030bdbcfe18

Changed in nova:
status: In Progress → Fix Committed
Monty Taylor (mordred) on 2012-03-09
Changed in openstack-ci:
status: Triaged → Fix Released
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
milestone: none → essex-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers