OpenStack Compute (Nova)

python2.6 setup.py clean -a returned exit code 1

Reported by Dan Prince on 2011-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Vish Ishaya

Bug Description

Looks like setup.py now fails to work due to the following error:

error in nova setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers
dh_auto_clean: python2.6 setup.py clean -a returned exit code 1

----

My guess is the recent change to pip-requires to use a git URL is the cause:

Specifically this pip-requires line:

-e git+https://review.openstack.org/p/openstack/python-novaclient.git#egg=python_novaclient-dev

Dan Prince (dan-prince) on 2011-12-08
Changed in nova:
importance: Undecided → High
Vish Ishaya (vishvananda) wrote :

yeah it also broke jenkins so it was a little tricky to fix. Should be working now

Changed in nova:
assignee: nobody → Vish Ishaya (vishvananda)
status: New → Fix Committed
Thierry Carrez (ttx) on 2011-12-14
Changed in nova:
milestone: none → essex-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers