OpenStack Compute (Nova)

Error during report_driver_status(): 'LibvirtConnection' object has no attribute '_host_state'

Reported by bastichelaar on 2011-11-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Édouard Thuleau

Bug Description

Running:
 - Diablo trunk
 - LXC hypervisor
 - DistributedScheduler

When nova-scheduler checks for the host status it fails with error:

2011-11-08 22:59:09,554 INFO nova.compute.manager [b0ac7c5d-f58b-43c6-8e67-cef87be9bd7d None None] Updating host status
2011-11-08 22:59:09,555 WARNING nova.compute.manager [b0ac7c5d-f58b-43c6-8e67-cef87be9bd7d None None] Error during report_driver_status(): 'LibvirtConnection' object has no attribute '_host_state'

I did some research, and in nova/virt/libvirt/connection.py line 202 it wants to get HostState(self._session), but self._session is not an object with the libvirt driver. In the Xen and other drivers it is declared. Only I dont know what it should be in this case.

Changed in nova:
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → Édouard Thuleau (ethuleau)
bastichelaar (bas-t) wrote :

Works for me now, thanks!

Reviewed: https://review.openstack.org/1456
Committed: http://github.com/openstack/nova/commit/1ecd70f23ae211c5c4ea5613adc24c0e1557790d
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 1ecd70f23ae211c5c4ea5613adc24c0e1557790d
Author: ��douard Thuleau <email address hidden>
Date: Wed Nov 9 17:37:54 2011 +0100

    Bug #887805 Error during report_driver_status(): 'LibvirtConnection' object has no attribute '_host_state'

    Fixes the host status reports from LibvirtConnection driver.
    This fix initializes in class 'LibvirtConnection', the local variable
    '_host_state' and replaces the variable 'session' by the local
    variable 'read_only'.

    Change-Id: Ia3ba29dc287c793c79a2bbde0d5ec69eb6ada480

Changed in nova:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2011-12-12
Changed in nova:
milestone: none → essex-2
importance: Undecided → Medium
Thierry Carrez (ttx) on 2011-12-14
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers