OpenStack Compute (Nova)

nova.crypto. generate_key_pair should handle OSError

Reported by Nachi Ueno on 2011-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Chris Fattarsi
OpenStack Quality Assurance
Fix Released
Medium
Unassigned

Bug Description

shutil.rmtree(tmpdir) may throw OSError. This should be handled.
https://github.com/openstack/nova/blob/stable/diablo/nova/crypto.py#L124

Nachi Ueno (nati-ueno) wrote :

generate_x509_cert() has same problem

Changed in nova:
assignee: nobody → Nachi Ueno (nati-ueno)
status: New → Confirmed
Changed in openstack-qa:
assignee: nobody → Nachi Ueno (nati-ueno)
importance: Undecided → Medium
status: New → Confirmed
Thierry Carrez (ttx) on 2011-11-08
Changed in nova:
importance: Undecided → Low
Nachi Ueno (nati-ueno) wrote :
Changed in nova:
status: Confirmed → In Progress
Changed in openstack-qa:
status: Confirmed → In Progress
tags: added: forward-port-needed
Nachi Ueno (nati-ueno) on 2011-11-18
Changed in nova:
assignee: Nachi Ueno (nati-ueno) → nobody
Changed in openstack-qa:
assignee: Nachi Ueno (nati-ueno) → nobody
Mark McLoughlin (markmc) wrote :

Moving from InProgress to Confirmed since nobody is assigned

Changed in nova:
status: In Progress → Confirmed
Changed in nova:
status: Confirmed → In Progress
assignee: nobody → Chris Fattarsi (chris-fattarsi)

Reviewed: https://review.openstack.org/4310
Committed: http://github.com/openstack/nova/commit/94d3d198555b550b1895e55f5199500709769b2c
Submitter: Jenkins
Branch: master

commit 94d3d198555b550b1895e55f5199500709769b2c
Author: chris fattarsi <email address hidden>
Date: Sun Feb 19 18:03:35 2012 -0800

    Handle OSError which can be thrown when removing tmpdir. Fixes bug 883326.

    Change-Id: Ie1f40fcce6ce6af4ab71961c725dcd626eda8aea

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
Nachi Ueno (nati-ueno) on 2013-09-25
Changed in openstack-qa:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers