OpenStack Compute (Nova)

XenAPI doesn't clean up failed build's VHDs

Reported by Josh Kearney on 2011-10-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Rick Harris

Bug Description

Failed build's VHDs continue to remain on the file system:

[root@xs ~]# ls -l /var/run/sr-mount/e0f61540-2d8e-e98b-a043-f7a6f0038ac1/ | wc -l
11
[root@xs ~]# xe vm-list
uuid ( RO) : 8aa565eb-6c5d-b328-7f4c-19aa9cbc46ec
     name-label ( RW): Nova
    power-state ( RO): running
uuid ( RO) : 7a570ee8-1d5b-467b-9c12-4a58f92fe2bc
     name-label ( RW): Control domain on host: xs
    power-state ( RO): running
uuid ( RO) : 068d3d7d-1249-2332-a9da-8fe1731e56b3
     name-label ( RW): XenServer DDK
    power-state ( RO): halted

Josh Kearney (jk0) on 2011-10-08
Changed in nova:
importance: Undecided → High
Thierry Carrez (ttx) on 2011-10-13
Changed in nova:
status: New → Confirmed

This could be a regression of bug #694935

However the original bug fix took care only of VDIs created from raw images in Glance/Objectstore.
The code for VHD download was added concurrently with this fix, and therefore currently lacks 'protection' against instance build failure. Therefore, if the bug has been observed while building instance from VHDs that would explain it. Otherwise it's a regression.

Rick Harris has made a lot of changes recently to fix problems where VDIs were leaking on failed builds:

https://review.openstack.org/#change,4713
https://review.openstack.org/#change,4731
https://review.openstack.org/#change,4836

I'm going to mark this as Fix Committed for now because of all of the work he has done. If VDIs are still seen leaking, please reopen (or open new bug) with details on the new failure.

Changed in nova:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
milestone: none → essex-rc1
status: Fix Committed → Fix Released
Mark McLoughlin (markmc) on 2012-04-03
Changed in nova:
assignee: nobody → Rick Harris (rconradharris)
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers