Allow ssl connections to the api server

Bug #869884 reported by Stanislaw Pitucha
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Wishlist
Ilya Alekseyev
oslo-incubator
Wishlist
Davanum Srinivas (DIMS)
Grizzly
Wishlist
Davanum Srinivas (DIMS)

Bug Description

API server allows only http connections at the moment. Since the underlying components allow SSL connections, this could be exposed in the configuration file.

Revision history for this message
Stanislaw Pitucha (stanislaw-pitucha) wrote :
Changed in nova:
status: New → Triaged
importance: Undecided → Medium
Brian Waldon (bcwaldon)
Changed in nova:
status: Triaged → In Progress
Revision history for this message
Mark McLoughlin (markmc) wrote :

Blueprint is https://blueprints.launchpad.net/nova/+spec/openstack-api-ssl

Patch hasn't been updated in 3 months, so I'm moving from InProgress to Confirmed

Of course, feel free to pick it up again Ahmad and Stanislaw!

Changed in nova:
status: In Progress → Confirmed
Thierry Carrez (ttx)
Changed in nova:
importance: Medium → Wishlist
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (master)

Fix proposed to branch: master
Review: https://review.openstack.org/4803

Changed in nova:
assignee: nobody → Ilya Alekseyev (ilyaalekseyev)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/5560

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/6862

Revision history for this message
Thierry Carrez (ttx) wrote :

Looks like you're not working on that anymore. Please set back to InProgress and reassign to you if you're working on proposing a change for merging.

Changed in nova:
assignee: Ilya Alekseyev (ilyaalekseyev) → nobody
status: In Progress → Confirmed
Changed in nova:
assignee: nobody → Davanum Srinivas (DIMS) (dims-v)
Changed in oslo:
assignee: nobody → Davanum Srinivas (DIMS) (dims-v)
status: New → Confirmed
Mark McLoughlin (markmc)
Changed in oslo:
importance: Undecided → Wishlist
Changed in oslo:
status: Confirmed → In Progress
Changed in nova:
status: Confirmed → In Progress
Changed in nova:
assignee: Davanum Srinivas (DIMS) (dims-v) → Ilya Alekseyev (ilyaalekseyev)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (master)

Reviewed: https://review.openstack.org/6862
Committed: http://github.com/openstack/nova/commit/7d31c7b15d4c929e384df0e114db615448601cc3
Submitter: Jenkins
Branch: master

commit 7d31c7b15d4c929e384df0e114db615448601cc3
Author: Ilya Alekseyev <email address hidden>
Date: Thu Jan 17 05:56:15 2013 -0500

    Adds SSL support for API server.

    Part of code in test for accessing with ipv6 and part of ssl
    socket wrapping developed by Davanum Srinivas.
    Original patch could be found here:
    https://review.openstack.org/#/c/19559

    DocImpact

    Fixes bug 869884.

    Change-Id: I6d60df77c3fb49552e597f94abae7f4d6f54044d

Changed in nova:
status: In Progress → Fix Committed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to oslo-incubator (master)

Reviewed: https://review.openstack.org/19452
Committed: http://github.com/openstack/oslo-incubator/commit/e50b68c0d28cb00fa627525f23bb0c0f614b9312
Submitter: Jenkins
Branch: master

commit e50b68c0d28cb00fa627525f23bb0c0f614b9312
Author: Davanum Srinivas <email address hidden>
Date: Fri Jan 11 00:10:56 2013 -0500

    Support for SSL in wsgi.Service

    Enable support for SSL as well using code from glance. We
    have some new options for configuring the SSL support.

    test_app starts wsgi.Service with a test app, then creates
    a url to make sure the http requests are actually served
    properly

    test_app_using_router adds wsgi.Router and Mapper() to the
    mix along with using the wsgify annotation for serving
    the http requests

    Fixes LP# 979488 (partial)
    Fixes LP# 869884 (partial)

    DocImpact

    Change-Id: Iae47b13b50e00c102c8c36f4a3e73b24fa4e6303

Changed in oslo:
status: In Progress → Fix Committed
Thierry Carrez (ttx)
Changed in nova:
milestone: none → grizzly-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in oslo:
milestone: none → grizzly-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in nova:
milestone: grizzly-3 → 2013.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers