nova-manage complains about missing nova-compute.conf

Bug #839796 reported by Adam Gandelman on 2011-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Unassigned
nova (Ubuntu)
Low
Unassigned

Bug Description

When nova-compute is located on other hosts, nova-manage complains about lack of nova-compute.conf:

:~# nova-manage help
[Errno 2] No such file or directory: '/etc/nova/nova-compute.conf'
ERROR:: Unable to open flagfile: /etc/nova/nova-compute.conf
help does not match any options:
 account
 agent
 config
 db
 drive
 fixed
 flavor
 floating
 host
 instance_type
 image
 network
 project
 role
 service
 shell
 user
 version
 vm
 volume
 vpn
 vsa

Related branches

affects: nova → ubuntu
affects: ubuntu → nova (Ubuntu)
Changed in nova:
status: New → Incomplete
status: Incomplete → New
Vish Ishaya (vishvananda) wrote :

Hmm, this looks like a packaging issue. It looks like by default the nova.conf is importing a new flagfile for nova-compute. If nova-compute isn't installed that file won't exist. The error won't actually stop anything from working, but it is annoying to see it pop up

Not sure about the best solution here, should nova-common install an empty nova-compute.conf that can be overwritten by the nova-compute package selected? Should nova-compute append --flagfile=nova.compute.conf to nova.conf when it is installed? Should we find a way to supress the error message in nova?

Robie Basak (racb) on 2011-09-05
Changed in nova (Ubuntu):
importance: Undecided → Low

Argh, I didn't realise there would be a warning if the file was missing.

Debian Policy forbids us from altering the contents of a conffile from
maintainer scripts, so we can't append to nova.conf when nova-compute
gets installed.

I suggest we either a --optional-flagfile that doesn't warn or perhaps
make it so that "--flagfile=@/some/path" silently ignores /some/path's
absence.

Thierry Carrez (ttx) on 2011-09-07
Changed in nova:
importance: Undecided → Low
status: New → Confirmed
Mark McLoughlin (markmc) wrote :

Why not just have nova-compute's init/upstart script run nova-compute with --flagfile=/etc/nova/nova-compute.conf and include nova.conf from there?

But it looks like --libvirt_type is needed in places other than just nova-compute?

Either way, something seems wrong. If you only need nova-compute.conf for the compute service, then my first suggestion should work. Otherwise, nova-compute.conf needs to always exist no?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2011.3-0ubuntu3

---------------
nova (2011.3-0ubuntu3) oneiric; urgency=low

  [Adam Gandelman]
  * debian/nova-common.postinst: Create 'nova' group, add user to it
    (LP: #856530)
  * debian/nova.conf, debian/nova-compute.upstart.in: Move reference of
    nova-compute.conf from nova.conf to nova-compute's argv. (LP: #839796)

  [Chuck Short]
  * debian/patches/backport-recreate-gateway-using-dhcp.patch:
    Makes sure to recreate gateway for moved ip. (LP: #859587)
  * debian/control: Update Vcs info.

  [ Scott Moser ]
  * debian/patches/fqdn-in-local-hostname-of-ec2-metadata.patch
    Make the 'local-hostname' in the EC2 Metadata service contain
    the domainname also. (LP: #854614)
 -- Chuck Short <email address hidden> Tue, 27 Sep 2011 14:56:59 -0400

Changed in nova (Ubuntu):
status: New → Fix Released
Russell Bryant (russellb) wrote :

As far as I can see, this was just a packaging issue and that has been resolved, so the nova bug can be closed out.

Changed in nova:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers