OpenStack Compute (Nova)

Event Notification: compute.instance.create: launched_at timestamp missing from event

Reported by Shawn Decuir on 2011-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Kevin L. Mitchell
Diablo
Undecided
Unassigned

Bug Description

<entry>
 <title>compute.instance.create</title><link href="http://10.13.136.195:8080/compute.instance.create/6f1828ff-1688-4d27-b0f7-15be1896f668" rel="alternate"></link>
 <id>tag:10.13.136.195:/compute.instance.create/6f1828ff-1688-4d27-b0f7-15be1896f668/</id>
 <summary type="html">compute.instance.create</summary>
 <content type="application/json">{"_context_roles": [], "_context_request_id": "e8e85042-698f-4b82-bc75-190911accaa7", "_context_read_deleted": false, "event_type": "compute.instance.create", "timestamp": "2011-08-18 19:27:08.111392", "priority": "INFO", "message_id": "6f1828ff-1688-4d27-b0f7-15be1896f668", "_context_auth_token": null, "_context_is_admin": true, "_context_project_id": null, "_context_timestamp": "2011-08-18T19:27:08.111416", "_context_user_id": null, "publisher_id": "compute.compute-10-13-135-248", "payload": {"display_name": "testserver", "tenant_id": "bwaldon-project", "created_at": "2011-08-18 19:27:55", "instance_type_id": 1, "instance_id": 7756, "instance_type": "256 slice", "image_ref": "7", "user_id": "bwaldon", "launched_at": ""}, "_context_remote_address": null}</content>
</entry>

<entry>
 <title>compute.instance.create</title><link href="http://10.13.136.195:8080/compute.instance.create/013c42ed-6861-429e-9b80-c818619f2bce" rel="alternate"></link>
 <id>tag:10.13.136.195:/compute.instance.create/013c42ed-6861-429e-9b80-c818619f2bce/</id>
 <summary type="html">compute.instance.create</summary>
 <content type="application/json">{"_context_roles": [], "_context_request_id": "4e5aca6f-6008-4a9d-811e-421d13abe1d0", "_context_read_deleted": false, "event_type": "compute.instance.create", "timestamp": "2011-08-18 19:26:07.475710", "priority": "INFO", "message_id": "013c42ed-6861-429e-9b80-c818619f2bce", "_context_auth_token": null, "_context_is_admin": true, "_context_project_id": null, "_context_timestamp": "2011-08-18T19:26:07.475732", "_context_user_id": null, "publisher_id": "compute.compute-10-13-135-237", "payload": {"display_name": "testserver", "tenant_id": "bwaldon-project", "created_at": "2011-08-18 19:26:54", "instance_type_id": 1, "instance_id": 7755, "instance_type": "256 slice", "image_ref": "7", "user_id": "bwaldon", "launched_at": ""}, "_context_remote_address": null}</content>
</entry>
<entry>
 <title>compute.instance.create</title><link href="http://10.13.136.195:8080/compute.instance.create/8c7ed271-ed16-48f0-826b-8fc2b90f31a2" rel="alternate"></link>
 <id>tag:10.13.136.195:/compute.instance.create/8c7ed271-ed16-48f0-826b-8fc2b90f31a2/</id>
 <summary type="html">compute.instance.create</summary>
 <content type="application/json">{"_context_roles": [], "_context_request_id": "305af3ca-780c-4bb3-8d18-f393f8111444", "_context_read_deleted": false, "event_type": "compute.instance.create", "timestamp": "2011-08-18 19:24:58.226611", "priority": "INFO", "message_id": "8c7ed271-ed16-48f0-826b-8fc2b90f31a2", "_context_auth_token": null, "_context_is_admin": true, "_context_project_id": null, "_context_timestamp": "2011-08-18T19:24:58.226634", "_context_user_id": null, "publisher_id": "compute.compute-10-13-136-66", "payload": {"display_name": "testserver", "tenant_id": "bwaldon-project", "created_at": "2011-08-18 19:27:15", "instance_type_id": 1, "instance_id": 7754, "instance_type": "256 slice", "image_ref": "7", "user_id": "bwaldon", "launched_at": ""}, "_context_remote_address": null}</content>
</entry>

Thierry Carrez (ttx) on 2011-09-07
Changed in nova:
importance: Undecided → Medium
status: New → Confirmed

Reviewed: https://review.openstack.org/1514
Committed: http://github.com/openstack/nova/commit/57e73d374843cade854f07a228192c4f496507ff
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 57e73d374843cade854f07a228192c4f496507ff
Author: Kevin L. Mitchell <email address hidden>
Date: Thu Nov 10 17:35:44 2011 -0600

    Fix a notification bug when creating instances

    Fixes a notifier bug that caused 'launched_at' to be empty and
    state to be reported as 'building', due to failure to refresh
    instance data prior to generating the notification. Fixes
    bug 834867.

    Change-Id: I70fbf3c67407c67b69040ee481ca6d51212cc55d

Changed in nova:
status: Confirmed → Fix Committed

Reviewed: https://review.openstack.org/2177
Committed: http://github.com/openstack/nova/commit/d565f3ad5917e90ab50a4b8ae9fe5079f70ed591
Submitter: Jenkins
Branch: stable/diablo

 tag in-stable-diablo
 done

commit d565f3ad5917e90ab50a4b8ae9fe5079f70ed591
Author: Kevin L. Mitchell <email address hidden>
Date: Thu Nov 10 17:35:44 2011 -0600

    Fix a notification bug when creating instances

    Fixes a notifier bug that caused 'launched_at' to be empty and
    state to be reported as 'building', due to failure to refresh
    instance data prior to generating the notification. Fixes
    bug 834867.

    (cherry picked from commit 57e73d374843cade854f07a228192c4f496507ff)

    Change-Id: I70fbf3c67407c67b69040ee481ca6d51212cc55d

Thierry Carrez (ttx) on 2011-12-14
Changed in nova:
milestone: none → essex-2
status: Fix Committed → Fix Released
Mark McLoughlin (markmc) on 2012-04-03
Changed in nova:
assignee: nobody → Kevin L. Mitchell (klmitch)
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers