OpenStack Compute (Nova)

DescribeInstances output does not return kernel or ramdisk

Reported by Scott Moser on 2011-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Hengqing Hu

Bug Description

When DescribeInstances api call is made, the result does not contain a kernel or a ramdisk for a running image:

$ euca-describe-images ami-00000017
IMAGE ami-00000017 smoser-ubuntu-images/ubuntu-lucid-10.04-amd64-server-20110719.img.manifest.xml available private x86_64 machine aki-00000016 instance-store
$ euca-run-instances ami-00000017 --key mykey.pem
$ euca-describe-instances i-000000c8
RESERVATION r-hm0g1p5n smoser_project default
INSTANCE i-000000c8 ami-00000017 10.55.60.8 10.55.60.8 running mykey 0m1.large 2011-08-16T19:37:19Z nova

As you can see, the ami had a kernel associated with it, but the DescribeInstances call returned nothing.

Thierry Carrez (ttx) on 2011-08-19
Changed in nova:
importance: Undecided → Medium
status: New → Confirmed
Changed in nova:
assignee: nobody → Ricardo Carrillo Cruz (rcc)
Changed in nova:
assignee: Ricardo Carrillo Cruz (rcc) → nobody
Hengqing Hu (hudayou) wrote :

After fix, the output looks like below
<pre>
RESERVATION r-ab10fsks nova_test default
INSTANCE i-00000003 ami-00000009 server-3 server-3 running key (nova_test, oneiric-server) 1 m1.tiny 2012-01-10T14:17:49Z nova aki-00000007 ari-00000008
</pre>

Changed in nova:
assignee: nobody → Hengqing Hu (hudayou)

Fix proposed to branch: master
Review: https://review.openstack.org/2933

Changed in nova:
status: Confirmed → In Progress
Hengqing Hu (hudayou) wrote :

Also, this patch should fix the instance not bootable problem.

Hengqing Hu (hudayou) wrote :

Note this TR relates to:

https://bugs.launchpad.net/nova/+bug/890486

But bug/890486's fix does not solve the whole problem.

This fix should address it.

Reviewed: https://review.openstack.org/2933
Committed: http://github.com/openstack/nova/commit/09fffd6928f5fa371ec66857eef394852b6c25e0
Submitter: Jenkins
Branch: master

commit 09fffd6928f5fa371ec66857eef394852b6c25e0
Author: Hengqing Hu <email address hidden>
Date: Tue Jan 10 23:08:13 2012 +0800

    Fix metadata mapping in s3._s3_parse_manifest.

    Fixes bug #827617

    Fixes incorrect output of the following euca2ools commands:
        'euca-describe-images'
        'euca-describe-instances'
    Which occours when user published 'ami' image with 'ari&aki' or 'aki'
    image(s).

    Fixes minor typo:
        'manifext' -> 'manifest'

    Change-Id: If32357e3ea6685476df9dbb6e74af710153457b9

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in nova:
milestone: none → essex-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-3 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers