OpenStack Compute (Nova)

inject_data disables routine filesystem checks in ext2, ext3, ext4 filesystems

Reported by Scott Moser on 2011-08-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Wishlist
Pádraig Brady

Bug Description

nova/virt/disk.py in inject_data does:

            # Configure ext2fs so that it doesn't auto-check every N boots
            out, err = utils.execute('tune2fs', '-c', 0, '-i', 0,
                                     mapped_device, run_as_root=True)

this disables both interval based and mount-count based filesystem checks on ext2 (or ext3 or ext4) file systems.

This is wrong for several reasons:
 a.) Just because the user is in the unfortunate position of using file injection does not mean they want to disable filesystem checks which help to prevent data loss.
 b.) I'm guessing the primary reason to modify this based on the fallacy that the first boot would then cause a filesystem check, and that filesystem check would be slow. That is not the case. A pristine image that has a filesystem check run on it due to a time interval passing happen sub-second. If the image had lots of changes since last fscheck, that is better fixed by the image author before registering.
 c.) injecting a file has nothing to do with disabling filesystem checks.

Scott Moser (smoser) on 2011-08-15
description: updated
Thierry Carrez (ttx) on 2011-08-19
Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in nova:
assignee: nobody → Pádraig Brady (p-draigbrady)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3679
Committed: http://github.com/openstack/nova/commit/a8104ebf127587cc9939a1990016d10f3bfcb146
Submitter: Jenkins
Branch: master

commit a8104ebf127587cc9939a1990016d10f3bfcb146
Author: Pádraig Brady <email address hidden>
Date: Thu Feb 2 18:16:02 2012 +0000

    remove auto fsck feature from file injection. Bug 826794

    This is at least independent of file injection,
    and as noted in the bug report is questionable
    to do anyway.

    Change-Id: Iddd33c446bad2232ea2d47cc30778228d1d222b0

Changed in nova:
status: In Progress → Fix Committed
Brian Waldon (bcwaldon) on 2012-02-02
Changed in nova:
milestone: none → essex-4
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers