OpenStack Compute (Nova)

EC2 API: Timestamps do not follow documented formats

Reported by George Reese on 2011-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Mark McClain

Bug Description

EC2 has the unfortunate tendency to support many different timestamp formats in different places. The OpenStack implementation supports non-standard date/time formats and does not follow the documentation. One example is the response from DescribeInstances for the launch timestamp, but the reality is this problem is pervasive.

Brian Waldon (bcwaldon) on 2011-08-30
Changed in nova:
status: New → Confirmed
importance: Undecided → Low
Chuck Short (zulcss) on 2011-10-25
tags: added: ec2
Changed in nova:
milestone: none → essex-rc1
Changed in nova:
importance: Low → Wishlist

A compatible EC2 API is obviously a wish list item.

On Mar 9, 2012, at 8:22 PM, Vish Ishaya wrote:

> ** Changed in: nova
> Importance: Low => Wishlist
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/823503
>
> Title:
> EC2 API: Timestamps do not follow documented formats
>
> Status in OpenStack Compute (Nova):
> Confirmed
>
> Bug description:
> EC2 has the unfortunate tendency to support many different timestamp
> formats in different places. The OpenStack implementation supports
> non-standard date/time formats and does not follow the documentation.
> One example is the response from DescribeInstances for the launch
> timestamp, but the reality is this problem is pervasive.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nova/+bug/823503/+subscriptions

--
George Reese - Chief Technology Officer, enStratus
e: <email address hidden> Skype: nspollution t: @GeorgeReese p: +1.207.956.0217
enStratus: Enterprise Cloud Management - @enStratus - http://www.enstratus.com
To schedule a meeting with me: http://tungle.me/GeorgeReese

Vish Ishaya (vishvananda) wrote :

I'm attempting to cut down the release blockers bug list by dividing it into stuff that means we can't ship vs. stuff that we can ship without but I would like it to make it. I (arbitrarily) decided to mark the nice to have stuff by targeting rc-1 and marking it wishlist, It wasn't intended to be a downgrade of the overall priority of the bug.

If you look here:

https://launchpad.net/nova/+milestone/essex-rc1

You will see that there are three ec2 api related bugs marked wishlist because no one has grabbed them to fix. I would very much like these to make rc-1, I just need someone to fix them. They all seem relatively easy, so I'm hoping someone will grab them and propose a fix.

Harish (harish-rajagopalan) wrote :

Hi,
I am a newbie n I m tryin to analyze this bug, to work on it. Could anyone pls tell me what is the documentation referred above or what is the documented format for the time-stamp?.

Changed in nova:
assignee: nobody → Mark McClain (markmcclain)
Thierry Carrez (ttx) wrote :

Let's use a tag instead

Changed in nova:
importance: Wishlist → Medium
milestone: essex-rc1 → none
tags: added: essex-rc-potential

Fix proposed to branch: master
Review: https://review.openstack.org/5409

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/5409
Committed: http://github.com/openstack/nova/commit/6a3e22a25c9ee3b259084df2f31c61b37f097e39
Submitter: Jenkins
Branch: master

commit 6a3e22a25c9ee3b259084df2f31c61b37f097e39
Author: Mark McClain <email address hidden>
Date: Thu Mar 15 15:47:23 2012 -0400

    fix timestamps to match documented ec2 api

    fixes bug: 823503

    Update to the dateTime format to provide three places of precision to
    microseconds. This change makes the API match the ec2 documents.

    Change-Id: I765e64e99042ade9fa996dfb1dee603d363f9b2c

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in nova:
milestone: none → essex-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers