Add memcache support to the ldap driver

Bug #707094 reported by Ryan Lane on 2011-01-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Vish Ishaya

Bug Description

Making the LDAP driver more generic means it becomes far more chatty. Certain actions cause a ton of lookups that could easily be cached. Since memcache is used for other parts of the codebase we should extend this to the ldap driver as well.

Related branches

Thierry Carrez (ttx) wrote :

Sounds like a good blueprint subject :)

Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed
Vish Ishaya (vishvananda) wrote :

This is actually a serious performance issue that makes ldap unusable. It takes over 2 seconds to do role checking for a regular user with the ldap driver. In the short term I consider caching roles a priority bugfix. A more complete caching method could be investigated in the future.

Changed in nova:
assignee: nobody → sleepsonthefloor (sleepsonthefloor)
importance: Wishlist → Medium
Thierry Carrez (ttx) on 2011-03-29
Changed in nova:
status: Confirmed → In Progress
Vish Ishaya (vishvananda) wrote :

Grabbing and updating anthony's branch, because he is busy at the moment.

Changed in nova:
assignee: sleepsonthefloor (sleepsonthefloor) → Vish Ishaya (vishvananda)
Thierry Carrez (ttx) on 2011-05-02
Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2011-06-02
Changed in nova:
milestone: none → diablo-1
Thierry Carrez (ttx) on 2011-09-22
Changed in nova:
milestone: diablo-1 → 2011.3
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers