There are two nova-api.conf files

Bug #705453 reported by Anne Gentle on 2011-01-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Wishlist
Kevin L. Mitchell
nova (Ubuntu)
High
Thierry Carrez

Bug Description

Two nova-api.conf files are installed:

/etc/nova/nova-api.conf
/etc/init/nova-api.conf

The /etc/init/nova-api.conf starts the nova-api service, so it cannot be renamed (according to ttx).

I believe the /etc/nova/nova-api.conf should be renamed, perhaps to further link it to paste.deploy or wsgi to avoid confusion between it and nova.conf.

Related branches

I think this bug also relates to this Bug #704985

Soren Hansen (soren) on 2011-01-20
description: updated
Thierry Carrez (ttx) wrote :

Confusing indeed. Only on Ubuntu though.

Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed
Thierry Carrez (ttx) on 2011-01-21
tags: added: ubuntu
Kevin L. Mitchell (klmitch) wrote :

I suggest renaming the paste config file to "nova-api.ini" or perhaps "api-paste.ini" if it always goes in a "nova" directory. Thoughts?

Changed in nova:
assignee: nobody → Kevin L. Mitchell (klmitch)
Brian Lamar (blamar) wrote :

"paste-config.ini" would work for me. Although, anything with "paste" in it would work to make sure that it's contents are obvious. +1 for all names with "paste" in them. :)

Jay Pipes (jaypipes) wrote :

I'd just like to note that a "paste config file" is nothing more than a regular config/ini file. The fact that nova-api.conf is a "flagfile" specific to gflags is the main issue here. So, I'd prefer that nova-api.conf be named nova-api.flags or something like that to indicate it is a non-standard configuration file compared to nova-api.conf, which indicates a standard configuration file used by ConfigParser or paste.deploy, which uses ConfigParser.

Thierry Carrez (ttx) wrote :

Jay: in fact the conflict is between /etc/nova/nova-api.conf (the paste config) and /etc/init/nova-api.conf (the upstart script). It has nothing to do with a potential gflags file ?

I'd rename it "nova-api.pasteconfig" or something like that (to make sure everyone knows it's about nova-api).

Jay Pipes (jaypipes) wrote :

Theirry, with all due respect, like I said, a paste config file is nothing more than a standard INI file. It is the GFlags nova-api.conf file that is non-standard, which is why I suggested changing the /etc/nova/nova-api.conf file to /etc/nova/nova-api.flags to indicate it is a non-standard configuration file...

But regardless, this naming issue I've brought up is a bikeshed issue at best.

Thierry Carrez (ttx) wrote :

Then I'm a bit confused. "/etc/nova/nova-api.conf" currently contains the nova-api paste config... You're suggesting we rename it to /etc/nova/nova-api.flags ?

No. Forget it... it's not important.

On Mar 1, 2011 8:11 AM, "Thierry Carrez" <email address hidden> wrote:

Then I'm a bit confused. "/etc/nova/nova-api.conf" currently contains
the nova-api paste config... You're suggesting we rename it to /etc/nova
/nova-api.flags ?

--
You received this bug notification because you are a member of Nova Bug
Team, which is subscrib...

Soren Hansen (soren) wrote :

2011/3/1 Jay Pipes <email address hidden>:
> The fact that nova-api.conf is a "flagfile" specific to gflags [...]

It's not. :)

There's an upstart job config file named /etc/init/nova-api.conf.
There's a paste config file named /etc/nova/nova-api.conf.
There's a flag file named /etc/nova/nova.conf.

The bug is about the confusion caused by the first two. Renaming the
paste one to say "paste" in the name sounds reasonable to me.

--
Soren Hansen        | http://linux2go.dk/
Ubuntu Developer    | http://www.ubuntu.com/
OpenStack Developer | http://www.openstack.org/

Kevin L. Mitchell (klmitch) wrote :

OK, the only consensus I've seen so far is that "paste" should be in the name. How about "api-paste.ini"--any objections to that specifically?

Changed in nova:
status: Confirmed → In Progress
Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) wrote :

This needs a matching change in Ubuntu packaging

Changed in nova (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
importance: Undecided → High
status: New → In Progress
Thierry Carrez (ttx) on 2011-03-08
Changed in nova (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2011.2~bzr786-0ubuntu1

---------------
nova (2011.2~bzr786-0ubuntu1) natty; urgency=low

  [Chuck Short]
  * New upstream version.

  [ Thierry Carrez (ttx) ]
  * nova-api.conf was renamed api-paste.ini (LP: #705453)

  [ Soren Hansen ]
  * Start on filesystem event rather than local-filesystems.
  * Weed out a *lot* of out-dated information from debian/control.
  * Create /var/lock/nova in upstart jobs and set lock_path in the
    flagfile.
  * Add dependency on python-novaclient.
 -- Chuck Short <email address hidden> Fri, 11 Mar 2011 09:41:45 -0500

Changed in nova (Ubuntu):
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2011-04-15
Changed in nova:
milestone: none → 2011.2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers