Image type is not taken into consideration when generating image ID

Bug #658234 reported by Soren Hansen on 2010-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Unassigned

Bug Description

Kernels and ramdisks get an ID assigned that starts with "ami-". That should be "aki-" and "ari-", respectively.

Rick Clark (dendrobates) on 2010-10-14
Changed in nova:
importance: Undecided → Low
Jay Pipes (jaypipes) wrote :

I assume this is only for the EC2 API?

Soren Hansen (soren) on 2010-11-03
Changed in nova:
status: New → Triaged
Josh Kearney (jk0) wrote :

It looks like this may have already been implemented (I see this is a fairly "old" ticket):

http://paste.openstack.org/show/188/

bzr blame doesn't give much information on this, so either the code above was always in place and simply isn't functioning, or the OP could be considered Merged/Released.

Chuck Short (zulcss) wrote :

Yes but it doesnt acutally work.

Soren Hansen (soren) wrote :

20:50 <+soren> jk0: The problem is that it's not the objectstore that assigns the id.
20:50 <+soren> jk0: The API server does.
20:50 <+soren> jk0: And the API server doesn't inspect the manifest to actually figure out if it's a kernel, ramdisk or machine image.

Soren Hansen (soren) on 2011-03-10
Changed in nova:
status: Triaged → Fix Committed
Thierry Carrez (ttx) on 2011-04-21
Changed in nova:
milestone: none → 2011.2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers