ERROR: Package 'bandit' requires a different Python: 2.7.17 not in '>=3.5'

Bug #1907438 reported by Lee Yarwood on 2020-12-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Lee Yarwood
Train
Undecided
Unassigned
OpenStack Object Storage (swift)
Undecided
Unassigned
neutron
Critical
Unassigned

Bug Description

The 1.6.3 [1] release has dropped support for py2 [2].

This should be capped within Nova's test-requirements.txt as linters are not covered by UC.

[1] https://github.com/PyCQA/bandit/releases/tag/1.6.3
[2] https://github.com/PyCQA/bandit/pull/615

Lee Yarwood (lyarwood) on 2020-12-09
description: updated
Lee Yarwood (lyarwood) wrote :

https://github.com/PyCQA/bandit/issues/663 suggests that this is due the 1.6.3 release being uploaded as a universal wheel [1].

[1] https://packaging.python.org/guides/distributing-packages-using-setuptools/#universal-wheels

Changed in nova:
status: New → Confirmed
Changed in swift:
status: New → Confirmed
Changed in neutron:
status: New → Confirmed
Changed in neutron:
importance: Undecided → Critical

This issue was fixed in the openstack/nova 20.5.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.