pdf-docs build failing on sphinx 3.1.0

Bug #1883200 reported by Ghanshyam Mann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
Undecided
Ghanshyam Mann

Bug Description

with the new release of sphinx 3.1.0, nova pdf docs build started failing with "! Dimension too large." error. That started failing since 10th June when the OpenStack requirement added a new constraint for sphinx.

Seems like somewhere TeX memory is exhausted during the pdf building. If I am not wrong we are hitting this open sphinx bug[1]. I checked the doc/source/_static/images dimensions first which is what I doubted at the very first place and there is no issue in images. Verified that by tried to build the pdf without images and got the same error.

- https://zuul.opendev.org/t/openstack/build/9c3e835ad5ee4842a07d77fdbaa6c97d/log/sphinx-build-pdf.log#7661

I cannot find any related changes in sphinx 3.1.0 also
- https://www.sphinx-doc.org/en/master/changes.html
- https://github.com/sphinx-doc/sphinx/commits/v3.1.0

[1] https://github.com/sphinx-doc/sphinx/issues/3099

Revision history for this message
Ghanshyam Mann (ghanshyammann) wrote :

After trying to hack that locally, our giant policy sample file is causing this error which we literalinclude in pdf doc build and end up exhausting the memory. I am not sure we have any best or any solution for that. Luckily neutron sample file is all good and did not cause this memory exhaustion.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to nova (master)

Related fix proposed to branch: master
Review: https://review.opendev.org/735279

Changed in nova:
assignee: nobody → Ghanshyam Mann (ghanshyammann)
status: New → In Progress
Revision history for this message
Ghanshyam Mann (ghanshyammann) wrote :

it is found that admin configuration files include the sample file for pdf which needs to be html only.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (master)

Reviewed: https://review.opendev.org/735279
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=b2f07a4959169fa42a263e6cae27d4b859808d00
Submitter: Zuul
Branch: master

commit b2f07a4959169fa42a263e6cae27d4b859808d00
Author: Ghanshyam Mann <email address hidden>
Date: Thu Jun 11 22:15:35 2020 -0500

    Fix pdf-docs build failing for TeX over capacity

    With the new release of sphinx 3.1.0, nova pdf docs build
    started failing with "! Dimension too large." error.
    That started failing since 10th June when the requirement added
    the new constraint for sphinx.

    Seems like somewhere TeX memory is exhausted during the pdf
    building (I think we are hitting this open sphinx bug[1]).
    While reproducing it locally I found that our giant policy sample
    file inclusion in pdf doc causing this error.

    - https://zuul.opendev.org/t/openstack/build/9c3e835ad5ee4842a07d77fdbaa6c97d/log/sphinx-build-pdf.log#7661

    We did skip the sample policy file for pdf in
    doc/source/configuration/index.rst but did not do that
    in admin configuration file and it start giving the error now.

    With this fix, sample policy file in admin config also is included
    in html but not in pdf.

    Closes-Bug: #1883200

    Change-Id: Iae143997138a5169a1e0fc76a74f9a0f09c03626

Changed in nova:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers