Kombu 4.6.4 is breaking with python 3.7

Bug #1840551 reported by Eric Fried on 2019-08-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Critical
Eric Fried

Bug Description

Since [0], nova's openstack-tox-py37 job is failing this many:

Status: Pass 97 Failure 17112 Skip 20

with this error:

TypeError: open: path should be string, bytes or os.PathLike, not _NormalAccessor

See this ML thread [1] for root cause analysis.

Proposed [2] against requirements to blacklist kombu 4.6.4.

[0] https://review.opendev.org/#/c/675816/
[1] http://lists.openstack.org/pipermail/openstack-discuss/2019-August/008553.html
[2] https://review.opendev.org/#/c/677070/

Eric Fried (efried) wrote :

https://review.opendev.org/#/c/677070/ is merged to blacklist kombu 4.6.4
https://review.opendev.org/#/c/677071/ ought to prevent similar snafus in future

Changed in nova:
status: In Progress → Fix Released
Eric Fried (efried) wrote :

This was fixed in eventlet 0.25.1.

Proposed [1] to revert [2] and blacklist eventlet 0.25.0.

[1] https://review.opendev.org/678078
[2] https://review.opendev.org/#/c/677070/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers