test_local_delete_removes_allocations_after_compute_restart failing since https://review.openstack.org/#/c/644591/

Bug #1821092 reported by Matt Riedemann on 2019-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Critical
Chris Dent

Bug Description

This just started failing:

http://logs.openstack.org/63/642863/1/gate/nova-tox-functional/6573680/job-output.txt.gz#_2019-03-20_15_58_21_993250

2019-03-20 15:58:21.993250 | ubuntu-bionic | {0} nova.tests.functional.regressions.test_bug_1679750.TestLocalDeleteAllocations.test_local_delete_removes_allocations_after_compute_restart [3.987199s] ... FAILED
2019-03-20 15:58:21.993360 | ubuntu-bionic |
2019-03-20 15:58:21.993431 | ubuntu-bionic | Captured traceback:
2019-03-20 15:58:21.993500 | ubuntu-bionic | ~~~~~~~~~~~~~~~~~~~
2019-03-20 15:58:21.993603 | ubuntu-bionic | Traceback (most recent call last):
2019-03-20 15:58:21.993894 | ubuntu-bionic | File "nova/tests/functional/regressions/test_bug_1679750.py", line 106, in test_local_delete_removes_allocations_after_compute_restart
2019-03-20 15:58:21.994042 | ubuntu-bionic | conf_fixture=placement_config, db=False) as placement:
2019-03-20 15:58:21.994359 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/fixtures/fixture.py", line 152, in __enter__
2019-03-20 15:58:21.994428 | ubuntu-bionic | self.setUp()
2019-03-20 15:58:21.994579 | ubuntu-bionic | File "nova/tests/functional/fixtures.py", line 66, in setUp
2019-03-20 15:58:21.994694 | ubuntu-bionic | super(PlacementFixture, self).setUp()
2019-03-20 15:58:21.995055 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/placement/tests/functional/fixtures/placement.py", line 66, in setUp
2019-03-20 15:58:21.995202 | ubuntu-bionic | conf.register_opts(self.conf_fixture.conf)
2019-03-20 15:58:21.995599 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/placement/conf/__init__.py", line 35, in register_opts
2019-03-20 15:58:21.995716 | ubuntu-bionic | logging.register_options(conf)
2019-03-20 15:58:21.996106 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/oslo_log/log.py", line 260, in register_options
2019-03-20 15:58:21.996277 | ubuntu-bionic | conf.register_cli_opts(_options.common_cli_opts)
2019-03-20 15:58:21.996691 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/oslo_config/cfg.py", line 2041, in __inner
2019-03-20 15:58:21.996852 | ubuntu-bionic | result = f(self, *args, **kwargs)
2019-03-20 15:58:21.997248 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/oslo_config/cfg.py", line 2327, in register_cli_opts
2019-03-20 15:58:21.997403 | ubuntu-bionic | self.register_cli_opt(opt, group, clear_cache=False)
2019-03-20 15:58:21.997731 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/oslo_config/cfg.py", line 2045, in __inner
2019-03-20 15:58:21.997840 | ubuntu-bionic | return f(self, *args, **kwargs)
2019-03-20 15:58:21.998171 | ubuntu-bionic | File "/home/zuul/src/git.openstack.org/openstack/nova/.tox/functional/local/lib/python2.7/site-packages/oslo_config/cfg.py", line 2319, in register_cli_opt
2019-03-20 15:58:21.998325 | ubuntu-bionic | raise ArgsAlreadyParsedError("cannot register CLI option")
2019-03-20 15:58:21.998533 | ubuntu-bionic | oslo_config.cfg.ArgsAlreadyParsedError: arguments already parsed: cannot register CLI option

Because of this change in placement: https://review.openstack.org/#/c/644591/

Matt Riedemann (mriedem) wrote :

There is a revert of the placement change here to unblock things: https://review.openstack.org/645014

Chris Dent is going to work on a longer-term fix which will go on top of a revert of the revert.

Fix proposed to branch: master
Review: https://review.openstack.org/645033

Changed in nova:
assignee: nobody → Chris Dent (cdent)
status: Confirmed → In Progress
Balazs Gibizer (balazs-gibizer) wrote :

As a side question: I think this bug could be avoided if we enable nova functional test run on placement patches. I suggested this before but at that time the agreement was that we don't want dependency between placement and the nova tests. This break shows that we already have such dependency because nova functional tests import placement code.

Reviewed: https://review.openstack.org/645033
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=0dfbcd74642b16432b800b51f304a89d762e3ff1
Submitter: Zuul
Branch: master

commit 0dfbcd74642b16432b800b51f304a89d762e3ff1
Author: Chris Dent <email address hidden>
Date: Wed Mar 20 22:23:27 2019 +0000

    Don't register placement opts mutiple times in a test

    The test_local_delete_removes_allocations_after_compute_restart test
    was trying to register placement config opts 3 times when only once
    is necessary, and if there are CLI opts being registered, only once is
    allowed. With change I4cd3d637878eb5bb798b78fd73f5be99e141da9d in
    placement, those opts gained some CLI opts, causing this test to
    fail.

    The depends-on is to a change in the placement-side PlacementFixture
    to make it possible to not register opts when calling the fixture,
    allowing the safe reuse of the already registered config.

    Depends-On: I360a306b5d05ada75274733038b73ec2f2bdc4d4
    Change-Id: I042e41ac8c41c0e5f0389904eb548e0e97d54c60
    Closes-Bug: #1821092

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 19.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers