nova-grenade-live-migration job failing on ubuntu bionic due to missing ceph package

Bug #1819944 reported by Ghanshyam Mann on 2019-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Dr. Jens Harbott

Bug Description

ceph hammer are not present in bionic and so nova-grenade-live-migration fail to run on bionic
- https://review.openstack.org/#/c/639017/8

http://logs.openstack.org/17/639017/8/check/nova-grenade-live-migration/735242b/ara-report/result/8816413c-7053-418f-886b-e238fdea1ec5/

10:59 AM E: Failed to fetch http://download.ceph.com/debian-hammer/dists/bionic/main/binary-amd64/Packages 404 Not Found [IP: 2607:5300:201:2000::3:58a1 80]

Matt Riedemann (mriedem) on 2019-03-13
Changed in nova:
status: New → Confirmed
summary: - nova-grenade-live-migration job failing on ubuntu bionic
+ nova-grenade-live-migration job failing on ubuntu bionic due to missing
+ ceph package
tags: added: ceph gate-failure grenade live-migration testing
Matt Riedemann (mriedem) wrote :

Looks like we should be getting it from luminous:

http://download.ceph.com/debian-luminous/dists/bionic/

(12:23:54 PM) coreycb: mriedem: hi, we have luminous in our bionic /queensrepos

Corey Bryant (corey.bryant) wrote :

The following looks like an error from atp:

10:59 AM E: Failed to fetch http://download.ceph.com/debian-hammer/dists/bionic/main/binary-amd64/Packages 404 Not Found [IP: 2607:5300:201:2000::3:58a1 80]

Can you just pick up ceph from ubuntu repos? For example, from /etc/apt/sources.list:

deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted

Corey Bryant (corey.bryant) wrote :

s/atp/apt

Matt Riedemann (mriedem) wrote :

It also looks like this should have already setup devstack-plugin-ceph to support bionic:

https://review.openstack.org/#/c/611594/

no longer affects: nova
Matt Riedemann (mriedem) wrote :

It's also failing in the nova-live-migration job so it's not about grenade, it's about the script at nova/tests/live_migration/hooks/ceph:

http://logs.openstack.org/17/639017/8/check/nova-live-migration/87084aa/logs/devstack-gate-post_test_hook.txt.gz#_2019-03-13_14_34_20_967

Matt Riedemann (mriedem) wrote :

As a workaround the ceph part of the nova live migration post-test-hook is being disabled.

no longer affects: devstack-plugin-ceph
Changed in nova:
status: New → Confirmed
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/643150

Changed in nova:
assignee: nobody → melanie witt (melwitt)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/643122
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=f8b578b2ac529fa74501c9d0796679712755c8d0
Submitter: Zuul
Branch: master

commit f8b578b2ac529fa74501c9d0796679712755c8d0
Author: ghanshyam <email address hidden>
Date: Wed Mar 13 17:55:16 2019 +0000

    Skip the ceph based live migration testing

    While moving the legacy jobs on Bionic[1], it is found
    that ceph pckg hammer is not available to download
    on bionic and it error with 404. Due to that job testing the
    live migration on ceph not working:
    - nova-live-migration skip the ceph live migration testing[2]
    - nova-grenade-live-migration fail due to no ceph pckg[3]

    To proceed further on Bionic migration which is blocked by these failure,
    this commit temporary skip the ceph live migration testing until
    bug#1819944 is fixed.

    Related-Bug: 1819944
    [1] https://review.openstack.org/#/c/639017
    [2] http://logs.openstack.org/17/639017/8/check/nova-live-migration/87084aa/logs/devstack-gate-post_test_hook.txt.gz#_2019-03-13_14_34_20_967
    [3] http://logs.openstack.org/17/639017/8/check/nova-grenade-live-migration/735242b/logs/devstack-gate-post_test_hook.txt.gz#_2019-03-13_15_00_32_310

    Change-Id: I05182d8fd0df5e8f3f9f4fb11feed074990cdb9f

Changed in nova:
assignee: melanie witt (melwitt) → Matt Riedemann (mriedem)
Matt Riedemann (mriedem) on 2019-03-14
Changed in nova:
assignee: Matt Riedemann (mriedem) → Dr. Jens Harbott (j-harbott)
Changed in nova:
assignee: Dr. Jens Harbott (j-harbott) → Eric Fried (efried)
Matt Riedemann (mriedem) on 2019-03-14
Changed in nova:
assignee: Eric Fried (efried) → Dr. Jens Harbott (j-harbott)

Reviewed: https://review.openstack.org/643150
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=9b2a7f9e7c9c24ad5b698f78681a1de1593b4a53
Submitter: Zuul
Branch: master

commit 9b2a7f9e7c9c24ad5b698f78681a1de1593b4a53
Author: melanie witt <email address hidden>
Date: Wed Mar 13 19:45:44 2019 +0000

    Re-enable Ceph in live migration testing

    Revert I05182d8fd0df5e8f3f9f4fb11feed074990cdb9f and
    Add fix to enable proper OS detection.

    Closes-Bug: #1819944

    Co-Authored-By: Jens Harbott <email address hidden>

    Change-Id: Iea6288fe6d341ee92f87a35e0b0a59fe564ab96c

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 19.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers