creating server with tags fails to get server tags in cells v1 job

Bug #1788129 reported by zhufl on 2018-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
zhufl

Bug Description

   Description
   ===========
   https://review.openstack.org/#/c/593984/ is to test creating server with tags in 2.52,
(https://docs.openstack.org/nova/latest/reference/api-microversion-history.html#id47)

and test_create_server_with_tags fails in nova-cells-v1 but succeeds in all other jobs

   Steps to reproduce
   ==================
   please see ci result http://logs.openstack.org/84/593984/2/check/nova-cells-v1/6b69992/

   Expected result
   ===============
   test_create_server_with_tags succeeds in all other jobs, so it's expected to pass also in nova-cells-v1

   Actual result
   =============
   test_create_server_with_tags fails in nova-cells-v1 but succeeds in all other jobs. (no tags after creating server with tags)

   Environment
   ===========
   community ci gate

   Logs & Configs
   ==============
   http://logs.openstack.org/84/593984/2/check/nova-cells-v1/6b69992/
Traceback (most recent call last):
       File "tempest/api/compute/servers/test_server_tags.py", line 126, in test_create_server_with_tags
         self.assertEqual(set(assigned_tags), set(fetched_tags))
       File "/opt/stack/new/tempest/.tox/tempest/local/lib/python2.7/site-packages/testtools/testcase.py", line 411, in assertEqual
         self.assertThat(observed, matcher, message)
       File "/opt/stack/new/tempest/.tox/tempest/local/lib/python2.7/site-packages/testtools/testcase.py", line 498, in assertThat
         raise mismatch_error
     testtools.matchers._impl.MismatchError: set(['tempest-tag-961725141', 'tempest-tag-1938292958']) != set([])

zhufl (zhu-fanglei) on 2018-08-21
description: updated
Matt Riedemann (mriedem) wrote :

I believe during review we intentionally did not add support for server tags when creating a server with cells v1 because cells v1 is deprecated:

https://review.openstack.org/#/c/459593/26/nova/conductor/manager.py@532

This isn't the first new feature in the API that we've omitted for cells v1 because it's deprecated. We'd need to blacklist the test:

https://github.com/openstack/nova/blob/722d5b477219f0a2435a9f4ad4d54c61b83219f1/devstack/tempest-dsvm-cells-rc

summary: - creating server with tags fails to get server tags
+ creating server with tags fails to get server tags in cells v1 job
Matt Riedemann (mriedem) wrote :

I've commented in the tempest patch, but I don't see why we need a tempest test for this, the functionality is already tested in the nova repo using functional tests and all we really need to test this is the nova API and DB. There are no other services involved.

Changed in nova:
status: New → Won't Fix
Changed in nova:
assignee: nobody → zhufl (zhu-fanglei)
status: Won't Fix → In Progress

Change abandoned by zhufl (<email address hidden>) on branch: master
Review: https://review.openstack.org/595399
Reason: not basic function, so test it on nova side

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers