placement can throw exception if webob<1.8 in use

Bug #1779287 reported by Sylvain Bauza on 2018-06-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Sylvain Bauza

Bug Description

With https://bugs.launchpad.net/nova/+bug/1773225 we addressed a better way to lookup HTTP headers but unfortunately the WebOb change wasn't backwards compatible with webob versions older than 1.8.

Since upstream requirements still support WebOb in 1.7.1 and higher (up to 1.8.2) [1], some Placement deployments could still using this 1.7 version and throw an AttributeError exception. For example, TripleO CI is reporting an incompatible usage in [2]

[1] https://github.com/openstack/requirements/blob/6766f353b2e814ecbd36dd08216022cf2024c03b/lower-constraints.txt#L18

[2] https://bugzilla.redhat.com/show_bug.cgi?id=1596308

Chris Dent (cdent) wrote :

This was fixed by raising the lower constraint: https://review.openstack.org/#/c/579110/

Changed in nova:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers