Vm created failed which booted from volumes cannot be deleted

Bug #1730549 reported by yangweiwei on 2017-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Stephen Finucane

Bug Description

When we used the following command to create a vm and it wasnot created successfully.

nova boot --flavor 1 --block-device id=314167fe-9eea-4e60-9dcd-24888930d85a,source=image,dest=volume,size=40,bootindex=0,voltype=vm1 --nic net-id=eeba976e-653d-42e0-9131-c196d80884a3 test

The created failed and the attachment in vm is None.
Then, we cannot delete the vm.

The error happened in libvirt driver. So it is needed fixed.

Zhenyu Zheng (zhengzhenyu) wrote :

You should probably add details about what you are tring to do here and maybe also attach related Error Log.

Fix proposed to branch: master
Review: https://review.openstack.org/518250

Changed in nova:
assignee: nobody → yangweiwei (496176919-6)
status: New → In Progress

Change abandoned by yangweiwei (<email address hidden>) on branch: stable/pike
Review: https://review.openstack.org/518198

Fix proposed to branch: master
Review: https://review.opendev.org/686997

Changed in nova:
assignee: yangweiwei (496176919-6) → Stephen Finucane (stephenfinucane)

Change abandoned by Stephen Finucane (<email address hidden>) on branch: master
Review: https://review.opendev.org/518250
Reason: This doesn't apply cleanly any more so I'm abandoning. Please re-open if you think this is still an issue

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers