Hyper-V: device metadata not updated

Bug #1723431 reported by Lucian Petrut on 2017-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Unassigned
compute-hyperv
Undecided
Unassigned

Bug Description

The Hyper-V driver does not update the instance device metadata when adding/detaching volumes or network interfaces to already existing instances.

tags: removed: drivers
description: updated
Changed in nova:
assignee: nobody → zhaozhilong (zhaozhilong)
assignee: zhaozhilong (zhaozhilong) → nobody
Changed in nova:
status: New → Confirmed
importance: Undecided → Low

Reviewed: https://review.openstack.org/511904
Committed: https://git.openstack.org/cgit/openstack/compute-hyperv/commit/?id=8326d2c43c3e464f0c2e3b58bf57b4ffb9a344e7
Submitter: Zuul
Branch: master

commit 8326d2c43c3e464f0c2e3b58bf57b4ffb9a344e7
Author: Lucian Petrut <email address hidden>
Date: Mon Oct 9 17:12:56 2017 +0300

    Update device metadata when attaching disks/NICs

    This change ensures that we're updating the instance device metadata
    when attaching or detaching instance volumes or NICs.

    Unlike the other Nova drivers, we're including all Cinder volumes
    in the device metadata, not just the tagged ones. The reason is that
    this allows Hyper-V guests to properly identify attached disk paths.

    Note that the disk mountpoints (e.g. /dev/sdc) are ignored by the
    Hyper-V driver. Also, we cannot override SCSI identifiers, unlike
    the Libvirt driver, which will use volume IDs as SCSI IDs.

    Closes-Bug: #1723431

    Depends-On: I7a4c242c80b5b3562bf9513deb89071b5bb5bf28
    Depends-On: I6f2c6ecf71d3254d64bc24574619c18184d3d055

    Change-Id: I6853b1d167fe675435f3fb8f1fdb0cf0b63bed65

Changed in compute-hyperv:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers