domain xml not well defined when using virtio-scsi disk bus

Bug #1686116 reported by Sahid Orentino on 2017-04-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Sahid Orentino
Ocata
Medium
Sahid Orentino

Bug Description

When using virtio-scsi we should be able to attach up to 256 devices but because the XML device definition do not specify which controller to use and place on that on that one, we are currently able to attach no more than 6 disks.

step to reproduce the issue:

- glance image-update --property hw_scsi_model=virtio-scsi <image>" to creates the virtio-scsi controller
- glance image-update --property hw_disk_bus=scsi <image>" disks will be using scsi

Start instance with more than 6 disks/volumes

Fix proposed to branch: master
Review: https://review.openstack.org/459737

Changed in nova:
assignee: nobody → sahid (sahid-ferdjaoui)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/459738

Fix proposed to branch: master
Review: https://review.openstack.org/459739

Fix proposed to branch: master
Review: https://review.openstack.org/459740

Fix proposed to branch: master
Review: https://review.openstack.org/459741

Jay Pipes (jaypipes) on 2017-05-31
summary: - domain xml not well defined when using virio-scsi disk bus
+ domain xml not well defined when using virtio-scsi disk bus
Changed in nova:
importance: Undecided → Medium

Reviewed: https://review.openstack.org/459737
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=724ca8227a23a918d1810f866af661ac2a0730a3
Submitter: Jenkins
Branch: master

commit 724ca8227a23a918d1810f866af661ac2a0730a3
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 05:42:41 2017 -0400

    libvirt: update LibvirtConfigGuestDeviceAddress to provide XML

    This commit is adding a method format_dom() to the config object
    LibvirtConfigGuestDeviceAddress. That in the aim to provide full
    description of the controller used by the device.

    Closes-Bug: #1686116
    Change-Id: I9620feffa74b8f7bc932eed03e3a60f46533681d

Changed in nova:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/459738
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=74ece03d70fac926a5e25eb0663da098e44cbaa2
Submitter: Jenkins
Branch: master

commit 74ece03d70fac926a5e25eb0663da098e44cbaa2
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 05:55:18 2017 -0400

    libvirt: set full description of the controller used by disk

    Adds to LibvirtConfigGuestDisk the ability to handle object to provide
    full description of the controller which should be used.

    Closes-Bug: #1686116
    Change-Id: Id796d9129ff850abd209f4e9e4e54ea77c477acf

Reviewed: https://review.openstack.org/459739
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=215add554adb88d9ded4267f07968d8a7d166a45
Submitter: Jenkins
Branch: master

commit 215add554adb88d9ded4267f07968d8a7d166a45
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 08:30:38 2017 -0400

    libvirt: rearange how scsi controller is defined

    This commit make just cleaner how we configure the
    scsi controller.

    Closes-Bug: #1686116
    Change-Id: I03b03962748db7081abd5aebf3578ddc4e30fe68

This issue was fixed in the openstack/nova 16.0.0.0b2 development milestone.

Reviewed: https://review.openstack.org/459740
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=fb343c402296c109af49bfca2f909680ca38a72b
Submitter: Jenkins
Branch: master

commit fb343c402296c109af49bfca2f909680ca38a72b
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 06:06:07 2017 -0400

    libvirt: update logic to configure device for scsi controller

    When using virtio-scsi it is possible to handle up to 256 disk but
    because we do not specifically set the information about the
    controller only 6 can be handled.

    This commit is fixing the issue by adding the address element to the
    disk configuration.

    Closes-Bug: #1686116
    Change-Id: I98e53b378cc99747765066001a0b51880543d2dd

Reviewed: https://review.openstack.org/459741
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=c25629f85feb53b5be0347f68c43b3b55fb9f137
Submitter: Jenkins
Branch: master

commit c25629f85feb53b5be0347f68c43b3b55fb9f137
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 08:04:26 2017 -0400

    libvirt: update the logic to configure volume with scsi controller

    This commit is fixing the issue by adding the address element to the
    volumes configuration.

    Closes-Bug: #1686116
    Change-Id: I701145abc0e300711a01889e8d62b1f7887da120

J-P methot (jphilippemethot) wrote :

Would it be possible to backport the patch to newton?

I don't think it's something possible, i mean the release management does not allow to backport fix in 2 releases before or that should be related to the security.

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/481136

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/481137

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/481138

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/481139

This issue was fixed in the openstack/nova 16.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/481135
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=e1092323e216203b7a7004f787c4061f97fad355
Submitter: Jenkins
Branch: stable/ocata

commit e1092323e216203b7a7004f787c4061f97fad355
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 05:42:41 2017 -0400

    libvirt: update LibvirtConfigGuestDeviceAddress to provide XML

    This commit is adding a method format_dom() to the config object
    LibvirtConfigGuestDeviceAddress. That in the aim to provide full
    description of the controller used by the device.

    Closes-Bug: #1686116
    Change-Id: I9620feffa74b8f7bc932eed03e3a60f46533681d
    (cherry picked from commit 724ca8227a23a918d1810f866af661ac2a0730a3)

Reviewed: https://review.openstack.org/481136
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=88927df9288b42b2f8f8f5b33f63b5a7530a863f
Submitter: Jenkins
Branch: stable/ocata

commit 88927df9288b42b2f8f8f5b33f63b5a7530a863f
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 08:30:38 2017 -0400

    libvirt: rearange how scsi controller is defined

    This commit make just cleaner how we configure the
    scsi controller.

    Closes-Bug: #1686116
    Change-Id: I03b03962748db7081abd5aebf3578ddc4e30fe68
    (cherry picked from commit 215add554adb88d9ded4267f07968d8a7d166a45)

Reviewed: https://review.openstack.org/481137
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=34a0ade4cc15f0bb2303c461b99bd481ed907a0f
Submitter: Jenkins
Branch: stable/ocata

commit 34a0ade4cc15f0bb2303c461b99bd481ed907a0f
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 05:55:18 2017 -0400

    libvirt: set full description of the controller used by disk

    Adds to LibvirtConfigGuestDisk the ability to handle object to provide
    full description of the controller which should be used.

    Closes-Bug: #1686116
    Change-Id: Id796d9129ff850abd209f4e9e4e54ea77c477acf
    (cherry picked from commit 74ece03d70fac926a5e25eb0663da098e44cbaa2)

Reviewed: https://review.openstack.org/481138
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=70ede864e74460d3cfde1c99c6a2879146b52dc4
Submitter: Jenkins
Branch: stable/ocata

commit 70ede864e74460d3cfde1c99c6a2879146b52dc4
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 06:06:07 2017 -0400

    libvirt: update logic to configure device for scsi controller

    When using virtio-scsi it is possible to handle up to 256 disk but
    because we do not specifically set the information about the
    controller only 6 can be handled.

    This commit is fixing the issue by adding the address element to the
    disk configuration.

     Conflicts:
     nova/virt/libvirt/driver.py

    Closes-Bug: #1686116
    Change-Id: I98e53b378cc99747765066001a0b51880543d2dd
    (cherry picked from commit fb343c402296c109af49bfca2f909680ca38a72b)

Reviewed: https://review.openstack.org/481139
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=be0f76ae6429e8d83fd99bd6c9365dfcd4702f42
Submitter: Jenkins
Branch: stable/ocata

commit be0f76ae6429e8d83fd99bd6c9365dfcd4702f42
Author: Sahid Orentino Ferdjaoui <email address hidden>
Date: Tue Apr 25 08:04:26 2017 -0400

    libvirt: update the logic to configure volume with scsi controller

    This commit is fixing the issue by adding the address element to the
    volumes configuration.

     Conflicts:
     nova/virt/libvirt/driver.py

    Closes-Bug: #1686116
    Change-Id: I701145abc0e300711a01889e8d62b1f7887da120
    (cherry picked from commit c25629f85feb53b5be0347f68c43b3b55fb9f137)

This issue was fixed in the openstack/nova 15.0.7 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers